Support » Plugin: Digress.it » Simple Steps To Upgrade Digress.it for WP 4.0.1

  • bradmkjr

    (@bradmkjr)


    I have reviewed the underlying code and found a few small changes which allow Digressit to work on WP 4.0+.

    These steps are what worked for me, I have not fully test 100% of the functionality of the plugin, but it restored front end functionality for my site.

    Step 1) Comment out outdated Google CDN jquery load

    if (!is_admin()) {
    //    wp_deregister_script( 'jquery' );
    //    wp_register_script( 'jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1.4/jquery.min.js');
    }

    line 715, 716 in core-functions.php /wp-content/plugins/digressit/core/core-functions.php

    This could be replaced by current CDN url, but just commenting out both lines works fine.

    Step 2) Fix small mistake in JS

    Replace:
    form_id+' . loading-bar , #'+form_id

    With
    form_id+' .loading-bar, #'+form_id

    Line 8 and Line 19 of /wp-content/plugins/digressit/core/js/digressit.core.min.js

    https://wordpress.org/plugins/digressit/

  • The topic ‘Simple Steps To Upgrade Digress.it for WP 4.0.1’ is closed to new replies.