Support » Theme: OceanWP » Simple Line Icons Load Time Issue

  • I am using google page insights and I am getting a 3.84 second load time for these Icons. I tried disabling through the Theme panel, but then my shop didn’t look right. The File that is causing it is Simple-Line-Icons.woff2 and it is in my /wp-content/themes/oceanwp/assets/fonts/simple-line-icons

    I am looking at pre-loading it, but when I opened the file it was not readable, and I was recently hacked, so is this a normal file? Guidance on what this file is, why it is taking almost 4 seconds to load, and best way to fix that load time would be appreciated.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 36 total)
  • Thread Starter kreish29

    (@kreish29)

    I added the following to the header.php file in my child theme. I copied the existing header.php file from the OceanWP theme and pasted it into my child theme and added the code. I am still getting the pre-load error

    <link rel=”preload” as=”font” href=”https://rjdunkin.com/wp-content/themes/oceanwp/assets/fonts/simple-line-icons/Simple-Line-Icons.woff2” as=”font” crossorigin=”anonymous”>

    I also tried using the exact URL page insights listed:
    <link rel=”preload” as=”font” href=”https://rjdunkin.com/wp-content/themes/oceanwp/assets/fonts/simple-line-icons/Simple-Line-Icons.woff2?v=2.4.0” as=”font” crossorigin=”anonymous”>

    Neither of these are working.

    Hello,

    We will check the issue and try to fix it in the future update of OceanWP.

    Thank you

    When?

    I have the same warning in Google Page speed insights. would be good to know how to resolve this. If its not fixable in the theme is there a plugin that can be used to preload simple line icons?

    Support team here?

    Sorry for the delay response. We will surely consider it in the next update of the theme.

    xandery711

    (@xandery711)

    Hi @kreish29, @fpadia, @ejjil, @apprimit,

    Running into the same issue. It is the exact same issue as when I run through @kreish29’s website in PageSpeed Insights. Is this confirmed an oceanwp issue? Is this being looked at in the next update? Thank you.

    Hi @kreish29, @fpadia, @ejjil, @apprimit, @xandery711

    Running into the same issue…
    When will the next update be published? Any news?

    Is there maybe a workaround? Thanks in advance.

    Same problem
    It is not a solution to be deactivated by theme script and style because they are important … search, basket, shopping card..
    Does it remain in your priorities, because Google will change the ranking algorithms in a few months and speed will be very important.? Thank you.

    kaffeemonks

    (@kaffeemonks)

    Hello Amit @apprimit

    Do you have any idea when this issue will be resolved?
    If it takes another 3 months, it might be easier to switch themes…

    Thank you.

    Same Problem. Fixing the problem would be nice.

    Hi! New 1.8.4. Updated unfortunately still didn´t solved the problem! Do you have any updates @apprimit ?

    Thank you.

    Hi There,

    Google Lighthouse reports a 7.5 second delay for my site as well.

    Any suggestions how to speed up the loading of the fonts?

    Thank you very much for your support!

    Christian

    Hi guys,

    if anyone still needs help with Google Lighthouse page speed optimization, we´ve found a solution. A friend of mine was able to solve the issue or respectively was able to find a workaround. We paid her only 150€ or so. Feel free to get in touch.

    Our scores are now at 70 for mobile and 93 for desktop much better than 12 🙂

    Cheers!
    Ps: Version 1.8.6. gives still the same error…

    bomdiabrasil

    (@bomdiabrasil)

    Hi Kaffemonks,

    Can you give us a hint what your friend did?

    Thanks!

Viewing 15 replies - 1 through 15 (of 36 total)
  • You must be logged in to reply to this topic.