WordPress.org

Support

Support » Plugins and Hacks » Simple Lightbox » [Resolved] Simple Lightbox with maxCDN

[Resolved] Simple Lightbox with maxCDN

Viewing 9 replies - 1 through 9 (of 9 total)
  • Further information on the problem with maxCDN that still remains after Simple Lightbox 1.5.5.1:

    On http://www.commbits.com/add-ons/network-security-appliance/screenshots/ the first thumbnail on the left does not use the maxCDN, and it works just fine. The rest use maxCDN and the window doesn’t open unless we shift-Click.

    Any ideas, anyone?

    Thank you

    Plugin Author Archetyped

    @archetyped

    Hi,

    What browser are you using when you experience the issue you describe?
    I’ve checked the URL you provided in Firefox, Chrome, and IE and all thumbnails open in the lightbox without issue.

    Hello Archetyped, and thank you for your response.
    You were able to open the thumbnails properly because we have subsequently and removed all /uploads from the CDN. This is a temporary fix, until we figure out the issue with the lightbox.
    I have now put back the images in the CDN so that you can see the problem.
    I can recreate this problem in IE8, Chrome, and Safari. In Firefox 3.6.13 something really weird is happening: Sometimes I see the popups sometimes not, even on the same thumbnails.

    I’ve tried with the lightbox css and js on or off the CDN but there is no change there. The problem persists.

    P.S. I have removed the top-left thumbnail from the CDN to demonstrate that if an image is not served by the CDN all is fine.

    Thanking you in advance for your attention to this issue that renders such a beautiful plugin useless.

    Any ideas?

    Plugin Author Archetyped

    @archetyped

    Hi,

    What other plugins are you using?

    The failure appears to be due to another script running prior to SLB.

    When a link to a CDN image is clicked, a Javascript error is occurring in another script (cf_tools.min.js served by Cloudflare), which cancels all other Javascript to be run when the link is clicked.

    In short, this means that the reason SLB is not working on those links is because an error occurs before SLB has a chance to run.

    Hello,

    There are many plugins on the site. Cloudflare is enabled in plugin W3 Total Cache. I have disabled Cloudflare and emptied all caching prior to testing this again, but my tests still fail.

    I do not see the js error you are referring to at my end, but your reply may be helpful. We need to do some more testing at our end.

    If you have any other ideas I would love to hear them.

    Thank you

    Plugin Author Archetyped

    @archetyped

    cf_tools.min.js is still being loaded in the page on my end.

    Hello Archetyped,

    Just wanted to let you know that the problem disappears with the “FancyBox for WordPress, 2.7.5” plugin instead. All other settings and agents (Cloudflare with maxCDN) remained the same.

    I hope this helps.

    Please post further info if you discover anything else on this.

    Thank you and best regards.

    Plugin Author Archetyped

    @archetyped

    Glad you found a solution for your issue.

    Were you running WP 3.2 when you first experienced the issue?

    No, the issue was first experienced prior to the WP 3.2 update the other day, and persisted with WP 3.2 as well.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Simple Lightbox with maxCDN’ is closed to new replies.
Skip to toolbar