Simple Lightbox
[resolved] Simple Lightbox and NextGEN conflict (5 posts)

  1. ViPeRx007
    Posted 2 years ago #

    I'm using NextGEN for a photo gallery page but would like to use Simple Lightbox on another page where I have some text links that I want to open images in a lightbox. Unfortunately, when I click on an image in the Photo Gallery now it tries to open up two lightboxes because NextGEN's gallery has a lightbox display and the Simple Lightbox wants to open it's own as well.

    Is there a way to set Simple Lightbox to only work on specific pages? I see there is an option to disable them on pages in general, but not specific ones.

    Maybe there's something I can do in NextGEN instead to resolve this but thought I'd start here.


  2. ViPeRx007
    Posted 2 years ago #

    This was kind of a dumb question. After thinking about it I realized I could just disable the lightbox functionality in the NextGEN settings and let Simple Lightbox do that part.

    So this is what I did:

    1) Leave Simple Lightbox as it is.

    2) On NextGEN go to Gallery -> Options -> Effects and set "Javascript Thumbnail effect" to None.

  3. Archetyped
    Plugin Author

    Posted 2 years ago #

    Yes, that is exactly what you should have done. Disabling NextGEN's lightbox functionality allows SLB to handle lightbox duties for NextGEN galleries.

    Great job!

  4. TraciBunkers
    Posted 2 years ago #

    Thank you! That worked for me. Something is wrong with my nextgen gallery lightbox, so I was looking for a fix. This plugin did it, and disabling the nextgen's thumbnail effects made this work.

  5. Archetyped
    Plugin Author

    Posted 2 years ago #

    Great to hear! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Simple Lightbox
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic