Support » Plugin: Simple History – user activity log, audit tool » Simple history plugin not loading history in dashboard

  • Resolved abdulsamad544

    (@abdulsamad544)


    iris.min.js:5 Uncaught TypeError: (intermediate value).setHSpace is not a function
    at h.<computed>.<computed>._create (iris.min.js:5)
    at h.<computed>.<computed>.h.isFunction.a.<computed> [as _create] (widget.min.js:11)
    at h.<computed>.<computed>._createWidget (widget.min.js:11)
    at new h.<computed>.<computed> (widget.min.js:11)
    at HTMLInputElement.<anonymous> (widget.min.js:11)
    at Function.each (jquery.js:2)
    at a.fn.init.each (jquery.js:2)
    at a.fn.init.h.fn.<computed> [as iris] (widget.min.js:11)
    at h.<computed>.<computed>._create (color-picker.min.js:2)
    at h.<computed>.<computed>.h.isFunction.a.<computed> [as _create] (widget.min.js:11)

    This error appears in console log when simple history is opened at dashboard and loader takes forever spinning saying Loading history…

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter abdulsamad544

    (@abdulsamad544)

    However we are able to export history in CSV means database is working fine.

    Plugin Author eskapism

    (@eskapism)

    Simple History does not use the iris.min.js javascript that seems to trigger the error. My guess is that another plugin is causing that error and that error prevents other scripts – including Simple History – from loading. Try to deactivate all other plugins and see if that helps and then enable them again one by one until the log stops working again.

    • This reply was modified 2 years, 1 month ago by eskapism.

    I’m seeing the same thing – not a problem for me as I can look at the CSV, but because the site has minimal plugins I thought it might help isolate the cause.

    Limit log in attempts reloaded
    Simple History
    UpdraftPlus – Backup/Restore
    WP Force SSL
    WPS Hide Login
    Yandex Metrica

    Now working beautifully 🙂

    Plugin Author eskapism

    (@eskapism)

    @gidseo Good to hear it’s working! 👍 Did you do anything specific to make it work again?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Simple history plugin not loading history in dashboard’ is closed to new replies.