Support » Fixing WordPress » Simple gallery functionalities

  • Resolved flyerjet

    (@flyerjet)



    Hello.

    I’m new to WordPress, and searched fo a while for something which is probably really basic, but could not find anything.

    On a post, I want to create a simple gallery with two pictures. I want to have the thumbnails in the post and get the full size picture when I click on it.

    Easy.

    But when I clicked on one of the pictures, I want to be able to navigate among the two (next/previous).

    Not easy.

    What I tried :
    Test 1 : Add Media > Create Gallery > Choose “Link to Media File” > Insert Gallery
    => Result : I get a gallery but no next/previous button. When I try to navigate with my keyboard arrows, I loop on the same picture.

    Test 2 : choose “Link to attachement page” instead.
    => Result : this time, when I click on one of the pictures, I get an error “Image cannot be loaded. Make sure the path is correct and image exist.”

    Any idea ?

    Thank you !

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • This is standard behavior for the WordPress gallery. What you need is to use a “lightbox” plugin that will give you the ability to switch between photographs.

    You can use popup image plugins or connect lightbox, fancybox or other libraries.
    If you are interested I can recommend libraries.

    Thank you for your answers.
    I can’t believe this is not standard behavior. WordPress is such high-end and well thought, it seems like basic functionnality…

    Maybe I don’t grasp all the implications…

    Thank you so much, I’ll try the recomended plugins !

    By the way, how come the gallery offers a “Link to attachement page” option when it seems to allways result in an error message ?

    seems to allways result in an error message

    It shouldn’t. You may have a server configuration issue. I would suggest checking your server error logs and/or enabling WP_DEBUG. If you can’t sort it out from there, you should start a new thread for this issue.

    Thank you so much !
    I will try that and act accordingly.
    Thanks !

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.