WordPress.org

Forums

Participants Database
[resolved] Signup now not working (11 posts)

  1. blobbi
    Member
    Posted 1 year ago #

    My signup page was working beautifully and now it is not. I am unsure why. Could you help?

    http://www.wildmedic.co.uk/bvm/

    https://wordpress.org/plugins/participants-database/

  2. blobbi
    Member
    Posted 1 year ago #

    when I click the sign up button it just goes back to a blank form

  3. blobbi
    Member
    Posted 1 year ago #

    No idea what happened. I uninstalled and reinstalled the plugin and it now works as it did before. Slightly annoying as I now have to enter all of the database again but works fine now.

  4. blobbi
    Member
    Posted 1 year ago #

    Ok, so it was due to captcha. Again I do not know why but when I added this it stopped working again? Any tips?

  5. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    Probably you don't have the "bcmath" module installed in your PHP. You'll need to talk to your web host about this.

  6. blobbi
    Member
    Posted 1 year ago #

    Not sure about that but I will check, thanks for getting back to me. Strange though as this plugin worked beautifully with the captcha working and then stopped suddenly.

  7. blobbi
    Member
    Posted 1 year ago #

    bcmath is installed

  8. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    Then you need to look at your PHP error log after you try to use the signup form with the CAPTCHA. Post whatever errors you see here.

  9. blobbi
    Member
    Posted 1 year ago #

    [26-Jun-2014 13:05:44 Europe/London] WordPress database error Incorrect parameter count in the call to native function 'FIELD' for query SELECT f.id FROM wildmedic_participants_database_fields f WHERE f.name IN ("") ORDER BY FIELD("") made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/Divi 2/page.php'), the_content, apply_filters('the_content'), call_user_func_array, do_shortcode, preg_replace_callback, do_shortcode_tag, call_user_func, Participants_Db::print_signup_form, Participants_Db::print_signup_class_form, PDb_Signup::print_form, PDb_Signup->__construct, PDb_Shortcode->_print_from_template, PDb_Signup->_include_template, include('/plugins/participants-database/templates/pdb-signup-default.php'), PDb_Signup->print_form_head, PDb_Shortcode->_print_form_head, PDb_Base::get_field_indices
    [26-Jun-2014 12:25:32 UTC] PDb_Signup::_mail sending failed for: Dexter
    [26-Jun-2014 12:48:19 UTC] PDb_Signup::_mail sending failed for: Stacey
    [26-Jun-2014 12:54:55 UTC] PDb_Signup::_mail sending failed for: Nick
    [26-Jun-2014 17:04:07 UTC] Participants_Db::_process_retrieval sending returned false
    [26-Jun-2014 17:20:49 UTC] PDb_Signup::_mail sending failed for: Osman
    [27-Jun-2014 08:59:21 UTC] Participants_Db::_process_retrieval sending returned false
    [27-Jun-2014 09:27:45 UTC] Participants_Db::_process_retrieval sending returned false
    [27-Jun-2014 09:38:57 UTC] PDb_Signup::_mail sending failed for: Julia
    [27-Jun-2014 09:49:49 UTC] PDb_Signup::_mail sending failed for: Andrew
    [27-Jun-2014 09:53:02 UTC] PDb_Signup::_mail sending failed for: Young
    [27-Jun-2014 09:56:22 UTC] PDb_Signup::_mail sending failed for: Ian
    [27-Jun-2014 09:58:48 UTC] PDb_Signup::_mail sending failed for: Heidi
    [27-Jun-2014 10:01:45 UTC] PDb_Signup::_mail sending failed for: Theodore
    [27-Jun-2014 10:04:09 UTC] Participants_Db::_process_retrieval sending returned false
    [27-Jun-2014 21:55:34 UTC] Participants_Db::_process_retrieval sending returned false
    [27-Jun-2014 22:21:56 UTC] Participants_Db::_process_retrieval sending returned false
    [27-Jun-2014 22:51:13 UTC] Participants_Db::_process_retrieval sending returned false

  10. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    Nothing that indicates the CAPTCHA is the problem. Looks like your mail handler is not working. I'd suggest reading my Email Troubleshooter, you may need to install an SMTP plugin.

    Also, check to make sure you have at least one column configured to display in both the admin and frontend lists (admin column and display column) on the manage database fields page. That is causing the first error.

  11. blobbi
    Member
    Posted 1 year ago #

    Xnau, thanks fro getting back to me and your time, I really do like the plugin.

    I am now really confused. I put the CAPTCHA back in but this time on the personal part of the database and it now works. I'm going to leave it alone now as I don;t want to break it again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Participants Database
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.