Support » Plugin: Post SMTP Mailer/Email Log » Signature Version 2 is deprecated for use with SES

  • Resolved farahnahle

    (@farahnahle)


    I’m receving this error:

    You getting this message because an error detected while delivered your email.
    For the domain: xxxx
    The log to paste when you open a support issue:
    Signature Version 2 is deprecated for use with SES from March 26, 2021. From that date on, we are progressively rejecting such requests. To resolve the issue, you must migrate to Signature Version 4. If you created your SMTP credentials in the SES Console, please create new credentials and replace the former ones. If you are deriving Signature Version 2 credentials from a IAM user, please start using the Signature Version 4 algorithm: https://docs.aws.amazon.com/ses/latest/DeveloperGuide/smtp-credentials.html

    What should I exactly do?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Tim

    (@tneville)

    Hi @farahnahle,

    Please paste a copy of your Post SMTP diagnostics log.

    Kind Regards,
    Tim

    Thread Starter farahnahle

    (@farahnahle)

    Hi @tneville ,
    Kindly find below the Diagnostic Test result. I replaced some personal info with xxxx(host) and yyyy(domain):

    Mailer: postsmtp
    HostName: xxxx
    cURL Version: 7.75.0
    OpenSSL Version: NSS/3.53.1
    OS: Linux ……..
    PHP: Linux 5.6.40 C
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=Yes, mcrypt=Yes, zlib_encode=Yes
    WordPress: 5.7 en_US UTF-8
    WordPress Theme: Anga
    WordPress Plugins: All in One SEO, Anga add-ons, ARI Fancy Lightbox, Contact Form with Recaptcha, Disable XML-RPC, FooGallery Owl Carousel Template, FooGallery, Forty Four - 404 Plugin for WordPress, Google Analytics, WPBakery Page Builder, Lazy Load, Parallax Backgrounds for VC, PopupAlly, Post SMTP, Post Types Order, Rename wp-login.php, Category Order and Taxonomy Terms Order, Velvet Blues Update URLs, Visual Link Preview, Wordfence Security, WordPress Importer, YITH Infinite Scrolling
    WordPress wp_mail Owner: /var/www/xxxx/wp-content/plugins/post-smtp/Postman/PostmanWpMailBinder.php
    WordPress wp_mail Filter(s): wp_staticize_emoji_for_email, PostsmtpMailer->get_mail_args
    WordPress wp_mail_from Filter(s): wordfence::fixWPMailFromAddress
    WordPress phpmailer_init Action(s): PostsmtpMailer->phpmailer_smtp_init
    Postman: 2.0.23
    Postman Sender Domain (Envelope|Message yyyy | yyyy
    Postman Prevent Message Sender Override (Email|Name): No | No
    Postman Active Transport: SMTP (smtp:tls:plain://email-smtp.us-west-2.amazonaws.com:587)
    Postman Active Transport Status (Ready|Connected): Yes | Yes
    Postman Deliveries (Success|Fail): 233 | 14
    • This reply was modified 1 month, 3 weeks ago by farahnahle.
    • This reply was modified 1 month, 3 weeks ago by farahnahle.
    Plugin Author yehudah

    (@yehudah)

    You should get a mail with instructions from Amazon, but here the important part:

    To migrate to Signature Version 4, please replace your existing SMTP credentials using the appropriate procedure relative to your setup:
    
    If you generated your SMTP credentials using the SES Console, simply create new credentials and replace your existing credentials with the new ones.
    If you derived your SMTP credentials from your AWS credentials, make sure you are using the Signature Version 4 algorithm. If you rely on a library to do this conversion, check if the library has a newer release that uses Signature Version 4 algorithm and migrate to it. Otherwise, you will need to either derive the credentials from another library that uses Signature Version 4 algorithm or generate credentials using the SES console.
    Plugin Support Tim

    (@tneville)

    Hi @farahnahle,

    We haven’t heard from you in a while, so I’ll mark this thread as resolved. If you have any further questions please feel free to open a new thread, and link to this one.

    Kind Regards,
    Tim

    Thread Starter farahnahle

    (@farahnahle)

    Hello @tneville,

    I was monitoring this week if the error will occur again.
    We changed the credentials and since then the issue did not occur again till now.

    Thanks for your support!

    Kind Regards,
    Farah Nahle

    Plugin Support Tim

    (@tneville)

    Hi @farahnahle,

    Great news. Thanks.

    Kind Regards,
    Tim

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.