Support » Networking WordPress » sign up activation stopped working

  • I have a very strange problem with my site. Up until sunday the user registration was working perfectly. However now it has stopped entering the users sign up information into the database so that when they click the link in the activation email they get an error.

    As far as I am aware nothing has been changed on the site. Can anyone think why the query to enter a new user has stopped working? Or any ideas of things I can check as i’m afraid I am out of them!

    The registration has stopped working before but changing the password field in the wp_signups table to accept null values fixed it. This time I have no idea what is causing it. If I just run the wpmu_signup_user function it writes the info to the database but the activation link still doesn’t work. I can’t see any reason why when the site calls this function it doesn’t write to the database.

    I didn’t build this site I have just been asked to fix it. I have never used wordpress multi site before so any pointers on where I should be looking would be great. Am I even looking at the right function?

    Thanks Rachael

Viewing 5 replies - 1 through 5 (of 5 total)
  • What plugins are running?

    Hi, the pluggins that are running are

    BuddyPress (v1.2.3)
    bbPress Integration (v1)
    WPMU Enable bbPress Capabilities (v0.1)
    BuddyPress Usernames Only (v0.52)
    BP-Album+ (v0.1.8)
    BuddyPress Backwards Compatibilty (v0.6)
    Contact Form 7 (v2.2)
    LP Vanilla to BuddyPress data import (v1)
    MD5 Password Hashes (v1.0.1)
    Role Manager (v2.2.3)
    WP-Mail-SMTP (v0.8.6)

    and its version 2.9.2 of wordpress (it’s really hard to upgrade things due to the permissions on their server)

    Oh. You’re using WPMU, not MultiSite.

    Yeeeeaah. Upgrade first. Seriously.

    OK thanks, was hoping not to avoid that but never mind!

    Still can’t understand why it just stopped working for no reason. Internet fairies strike again…

    If you’ve been keeping your plugins up to date, that would be my first guess. The other is there’s something weird on your server that, when updated, broke things.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘sign up activation stopped working’ is closed to new replies.