WordPress.org

Forums

sidebar.php not updating after adding widgets (4 posts)

  1. 10dolla
    Member
    Posted 6 years ago #

    Okay I'm using the Cutline-1.4-3ColumnRight theme and this theme initially comes with a couple of widgets written into the sidebar.php file. I think it has the Search, Recent Entries, Archives, Categories, and Meta widgets as the default widgets.

    I want to redistribute these widgets among the two sidebars. For example, I think it initially has the Meta widget in the right sidebar and I would like to move it into the left side bar. Being somewhat unfamiliar with php files I decided to use wordpress's appearance menu to redistribute the widgets.

    I want to note that when I initially went to the widgets menu there weren't any widgets listed in the menu as having been added, even though they're listed in the sidebar.php files. After redistributing the widgets the way I wanted they function on the page fine, BUT the sidebar.php file is not updated in the theme folder to reflect the added widgets.

    Is the sidebar.php file supposed to be updated when you add widgets? Or is adding widgets via the appearance menu independent of the sidebar.php file in my theme folder?

    This is a problem because I want the search widget to be the first widget on my lefthand sidebar, but the search widget as added via the widget menu doesn't have a title, so I wanted to go into the sidebar.php file and add one manually..but if the file isn't updated to reflect the widgets I've added I don't know how to change it...

    Any help with this would be much appreciated!
    Thanks!

    -10dolla

  2. 10dolla
    Member
    Posted 6 years ago #

    bump?

  3. esmi
    Forum Moderator
    Posted 6 years ago #

    Is the sidebar.php file supposed to be updated when you add widgets?

    Depends on the theme. My guess is that you'll need to edit the sidebar files manually to redistribute the various menu sub-sections.

  4. FCGrabo
    Member
    Posted 5 years ago #

    I'm running Cutline 3-column-split v1.4-3 and I just can't get a text widget to save to the right sidebar, regardless if I enable accessibility mode.

    I wonder if this is a problem with the theme or WP 2.9.1.

Topic Closed

This topic has been closed to new replies.

About this Topic