WordPress.org

Forums

Sidebar Widgets Npt Updating Blog (23 posts)

  1. send2paul
    Member
    Posted 9 years ago #

    Hello again :O)

    So, I installed the sidebar widget. And activated it. And it is compatible to the WP theme I am using.

    I can increase the number of text links to 9 if I want to - and "save" that preference - and that works.

    But what doesn't work is when I drag and drop the individual blocks into the left and right sidebars. I click "save changes". I go to look at my blog - the changes haven't occured. I go back to the Manage Sidebar tab - and everything is set back to the default again.

    Is there something I should know? (as Duran Duran once sang in "Please, Please Tell Me Now" :O)), that I should/should not be doing?

    Thanks for your help here.

    Paul

  2. send2paul
    Member
    Posted 9 years ago #

    Okay - I'm still no nearer fidning out why my sidebar widget drag and drop does not update.

    I've even changed themes, and that hasn't helped. Is there anything else I have to do to make the sidebar widget work
    , apart from "activating" it in the plug-ins section of the WP control panel?

    Thanks

    Paul

  3. send2paul
    Member
    Posted 9 years ago #

    .... and then I have re-installed WP and re-installed the sidebar widget and tried again - still no luck.

    So, basically, everything is installed, but nothing "stays" once I drag n'drop and "save" the changes I have made.

    Is there anything else I have to do to make the sidebar widget work apart from "activating" it in the plug-ins section of the WP control panel?

    Or is there something else I am missing here?

    Paul

  4. yosemite
    Member
    Posted 9 years ago #

    Ok, I'll bite.

    Are you seeing any error messages?
    What version of WP?
    What theme are you using?
    Are you using any admin themes?

  5. send2paul
    Member
    Posted 9 years ago #

    No - I just drag an drop the blocks into the sidebars, then save.

    I go and look at the website - nothing has changed. I go back to the sidebar widget page, and everything is back to the default settings.

    (Thanks for biting!)

    Using the TIGRA theme
    Up-to-date version of WP - 2.03 is it?
    Admin themes? No, I don't think so

    Paul

  6. Go move things around, hit Save Changes. It should go back to the widgets page with a new "view site" thing up top. Instead of hitting that and *without reloading your blog page*, click the "Sidebar widgets" tab again, to reload the sidebar widgets config page. Are your widgets still in the same place, or did they reset back to empty widget bars again?

    If they still reset back to empty widget bars, without you ever loading the blog page, then I'd guess at some kind of database issue. No idea.

    If they don't reset until you actually load the blog page, then I'd suspect something being wrong with your template/theme that's causing this to occur.

  7. yosemite
    Member
    Posted 9 years ago #

    What otto42 said.

    Couple things to check (also): Make sure the scriptaculous directory made it to: wp-includes/js/scriptaculous

    Delete wp-content/plugins/widgets/widgets.php and re-upload it.

    Report back ;')

    PS It's the TIGA theme. :-P

  8. send2paul
    Member
    Posted 9 years ago #

    Okay - thanks peeps for the help.

    Did all that you said. (The scriptulous directory was intially in weidgets directory - as per the "read me" file in the widgets folder). Moved the scriptulous directory to the wp-includes/js/scriptaculous directory.

    Deleted wp-content/plugins/widgets/widgets.php and re-uploaded it.

    Now, the sidebar widget plugin is there as an option in the "presentation" tab. However - the icons to the right of some of the blocks, (enabling to give them titles etc), have now all disappeared.

    I am able to drag and drop the blocks, but do not want to go down that route as yet, in case the "missing icons" issue may also cause further problems.

    Paul

  9. yosemite
    Member
    Posted 9 years ago #

    However - the icons to the right of some of the blocks, (enabling to give them titles etc), have now all disappeared.

    Curious, what plugins do you currently have enabled?

  10. Is this server that you're running the blog on a Windows based server or a Linux based server?

  11. send2paul
    Member
    Posted 9 years ago #

    Thanks again for your help on this chaps.

    As all the server info stuff is something to do with the host, (and because I don't know any different), I'd say it was a Windows based server. (Do I need to check?)

    Below is a list, (which will probably look all funky and out of line when I post it!), of the ALL the other plug-ins I have and whether they are activated or not, i.e. if it says "active" in the Action column, that means it hasn't been activated yet.

    Plugin Version Action
    Akismet 1.15 Activate
    Adsense-Deluxe 0.7 Deactivate
    Hello Dolly 1.5 Activate
    wp-cache 2.0.17 Deactivate
    WP-Autoblog 1.0 Activate
    WP Database Backup 1.7 Deactivate
    Google Search widget 1.0 Activate
    del.icio.us widget 1.0 Activate
    Sidebar Widgets 1.0 Deactivate

    Thanks again for your help on this. I know nothing of .php and the workings of WP, but I really do appreciate the time and effort you guys spend in these forums helping out schmucks like me! :O)

    Paul

  12. yosemite
    Member
    Posted 9 years ago #

    This sounds familiar... http://www.samdevol.com/conflict-with-tiger-style-admin-and-wordpress-widgets/

    I was hoping it might be that simple. If it followed you across a different theme, that could point to a plugin as well, but yours seem fairly benign (although I don't know the adsense one).

    Personally, I usually forget to disable wp-cache (Options:wp-cache) when I am troubleshooting/making-changes which often has the effect of preventing the appearance of changes since I'm looking at a cached page :-P

    Hopefully someone far smarter then me (plenty of people here!) will wander by soon ;')

  13. send2paul
    Member
    Posted 9 years ago #

    Hmmmmm..... and it's troubling me as well! :)

    I think I'll go with a bit of trial and error tactics and remove all widgets and start to re-install one by one to see what happens.

    I don't suppose there's any issues with the length of default time in the wp_cache widgert being 3600 seconds, even if I did disable it whilst making changes?

    And there's no issues with having Zone Alarm, (I know - I'm grasping at straws here!), installed on my pc - or having issues with any pc preferences of any kind?

    Finally - I host with DreamHost. Any know of any WP issues and them? I use their "One-click" software install feature which loads WP for me into the right place for my server files, then you just go through the normal WP admin set up etc etc.

    Thanks again Yosemite and Otto42, (and anyone who happens by here!), for all your help and knowledge.

    Paul

  14. As all the server info stuff is something to do with the host, (and because I don't know any different), I'd say it was a Windows based server. (Do I need to check?)

    Not really. It's just that early versions of the widgets plugin had issues with Windows based servers. The current download of the widgets plugin from automattic.com doesn't have those issues any more, but if you don't have the latest download, then you could have problems similar to what you're describing, on a Windows server.

    Make sure you have the latest widgets download. http://automattic.com/code/widgets

  15. yosemite
    Member
    Posted 9 years ago #

    3600 seconds is fine. When I disable wp-cache I scroll down and Delete Cache to make sure ;')

    When done making changes/edits/validating I just have to remember to turn it back on :-P

  16. send2paul
    Member
    Posted 9 years ago #

    Well - I've just given up. Sidebar widgets just will not work with me.

    The best I can get to is having all the blocks in the column on the left hand side to be selected.... I drag and drop the individual blocks into the left and right sidebars. I click "save changes". I go to look at my blog - the changes haven't occured. I go back to the Manage Sidebar tab - and everything is set back to the default again. (Or I go back to the "Sidebar Widgets" tab before I look at the new blog - and the everything has set back to it's "default settings").

    Disappointed of Essex, England

  17. yosemite
    Member
    Posted 9 years ago #

    I wondered if this might be a mod_security issue... But you should see an error message or get a 404 page or similar if that was the case.

    If you're with Dreamhost, they can help. Ask them about it, letting them know you have worked for some time to track this issue down... They might see something in your server error logs. Mention wordpress widgets ;')

    If you are on a windows server, why? Check and make sure. If nothing requires you to be on windows, ask dreamhost to move you to a linux server (though I suspect you're already on one).

  18. Webhostinguk
    Member
    Posted 9 years ago #

    You should make sure that sidebar.php is writable. Incase of Linux servers we set it to 777 to make changes in sidebar and make it 644 once again when you complete the changes. You should find sidebar.php inside wp-content/themes/yourtheme directory.

  19. send2paul
    Member
    Posted 9 years ago #

    Okay - back in the saddle again(!) - I contacted DreamHost earlier on today, but I am still awaiting a reply.

    I've looked at the "permissions" for the sidebar.php file and of the three categories, (Owner, Group and Everyone), both Group and Everyone has "read" and "write" permissions.

    The chmod value is set to 644.

    Does that help at all?

    Paul

  20. yosemite
    Member
    Posted 9 years ago #

    Nope. Leave the value at 644. Nothing is trying to make changes to your sidebar.php...

  21. send2paul
    Member
    Posted 9 years ago #

    Okay - I'll leave it. I'll wait to see what DreamHost comes back with.

    Time to watch some "footie" I think. See who England will play against in the Quarter Finals - Holland or Portugal? :)

    Thanks again for your help.

    Paul

  22. yosemite
    Member
    Posted 9 years ago #

    Portugal ;')

  23. mimmson
    Member
    Posted 8 years ago #

    I figured it out for me. Turn off your Firewall.

Topic Closed

This topic has been closed to new replies.

About this Topic