Support » Fixing WordPress » Sidebar Suddenly Not Loading

  • Resolved bwhitlock01

    (@bwhitlock01)


    I was doing some minor changes within the dashboard and settings, then suddenly when I loaded the page, the sidebar isn’t loading on the home page or single-post view. When I force the page into a 404 Not Found error (with a random /asdf;lkj page load), it shows up though. I don’t think I accidentaly turned it off (or even know you could), but who knows.

    -I’m running the theme “Cleanr.”
    -I have reinstalled to the current version of WP
    -I have tried a different theme (twenty eleven) and it doesn’t show up either
    -I have tried reinstalling the theme, to no avail.

    Again, the weirdest part is that it shows up on the error page, but not on the main post pages.

    Any help?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Minor update. It looks like the sidebar is loading, but it’s loading on the main section and below all the posts. This is weird.

    The site is http://www.bwhitlockphoto.com/blog

    For some reason the sidebar is too wide and can’t fir next tot the main content area (cause of the nature of how floats work). Try to shorten the text “Microblogs and Personal”. Anyway something is making your sidebar too wide.

    Or somehow the float is broken.

    Thanks. I’ve tried shortening that link category, but it didn’t fix it. Is there any CSS coding that I should be looking for in the Theme editor to tweak the sidebar placement and float?

    Is this even a Theme-related issue? I thought I ruled that out, but who knows.

    esmi

    (@esmi)

    Forum Moderator

    You have missing or mis-placed closing </div> tags in your theme template file. If in doubt, always validate a page first

    Michael

    (@alchymyth)

    Forum Moderator

    definitively a missing </div> in the content of the posts ‘turner field, home of …’ and ‘james loney’

    you can see that after clicking on the title, the single post has the same sidebar problem, while other single posts don’t.

    check the post content using the html mode of the post editor.

    You nailed it. Looks like that closing tag is what I was missing. Thanks a ton.

    I guess that’s what I get for trying to edit more code than I thought I had. :O

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Sidebar Suddenly Not Loading’ is closed to new replies.