WordPress.org

Forums

Frontier
[resolved] Sidebar problem (10 posts)

  1. liton1980
    Member
    Posted 1 year ago #

    I installed this theme and i didn't make any changes to it, and also i tested it by setting the size of sidebar low or high. I even set it to 400px, but the sidebar doesn't show as i want (in right side of website). It shows below the posts!!!
    How can i fix it?

  2. WPyogi
    Forum Moderator
    Posted 1 year ago #

    A link to your site will be helpful...

  3. liton1980
    Member
    Posted 1 year ago #

    I have installed it on a testing website to see the features of it. I also tested it on local-host but the problem is the same.

  4. ronangelo
    Member
    Theme Author

    Posted 1 year ago #

    The theme works fine on my end. I personally use this theme on at least 5 sites. There are also quite a lot of people that use it. We can't tell what's wrong with your site if we can't even inspect it. A link would really be helpful. Also, be sure to check the plugins that you're using.

    Are you using an old browser to view the site? This theme like many others, is written in html5 and css3 so don't expect old browser to be compatible.

  5. liton1980
    Member
    Posted 1 year ago #

    I have seen your theme on other websites and i am, sure it works well on them. But its strange for myself too. I use latest version of browsers. The problem is the same in Firefox, Chrome, IE and ... I think it has a conflict with one of installed plugin. I should find it by deactivating them one by one.

  6. liton1980
    Member
    Posted 1 year ago #

    I found the problem. The problem relates to Autoptimize plugin. When i disabled "Optimize CSS Code", the problem solved. Do you know anyway that i can compress and optimize CSS file of Frontier theme without facing that problem?

  7. Frank Goossens
    Member
    Posted 1 year ago #

    Hi guys;
    I'm the Autoptimize maitainer and happened to read this (wp-org matcher for the win). I've been able to trace this problem down to Autoptimize not handling the presence of a Byte Order Marks in the CSS-file very well.

    Download Converter Member; if you open up wp-content/plugins/autoptimize/classes/autoptimizeStyles.php and around line 105 change

    //<link>
    if($css !== false && file_exists($css) && is_readable($css))
    {
       $css = $this->fixurls($css,file_get_contents($css));
    }else{

    into

    //<link>
    if($css !== false && file_exists($css) && is_readable($css))
    {
       $css = $this->fixurls($css,file_get_contents($css));
       $css = preg_replace('/\x{EF}\x{BB}\x{BF}/','',$css);
    }else{

    (so adding that preg_replace-line, basically) then the BOM-character will get janked from the aggregated CSS-file and all will be well. I'll make sure this is in the upcoming 1.7.0 as well.

    hope this helps,
    frank

  8. liton1980
    Member
    Posted 1 year ago #

    @ futtta, Yes, i did it and it works well now. I am waiting for the next version of Autoptimizer. I have another question too. However i should make a new thread for it,. but as i asked it before and you answered me i ask it here. Please explain it more this time. If i want to place Google adsense ads on my pages and enable Optimization for JavaScript too, and i want to exclude Google adsense from caching, what is the exact name that i should enter in "Exclude scripts from autoptimize" ?

  9. Frank Goossens
    Member
    Posted 1 year ago #

    DC; I answered in your topic in the autoptimize support forum.

  10. liton1980
    Member
    Posted 1 year ago #

    OK, thanks. So i make this

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic