WordPress.org

Forums

Custom Sidebars
[resolved] Sidebar not appearing on Homepage (5 posts)

  1. dooleymark
    Member
    Posted 9 months ago #

    Hello,

    Using WP 3.9.1, theme Twenty Thirteen. I installed Custom Sidebars to add a Sidebar to my Homepage. That Sidebar does not show up on it.
    Yes, I did set select the Sidebar I edited that post -- because my Homepage is a post.

    Now, earlier on, I deleted a piece of code for the posts on my Homepage not to display post metadata. Is that by any chance what is preventing my Sidebar from showing up?

    Also, I noticed that when I edit the post to add the sidebar, on the bottom right corner when choose the sidebar, it doesn't say "main sidebar" to be replaced, but only "secondary widget area." Is that a clue to what is not working?

    So many thanks in advance for your help!

    https://wordpress.org/plugins/custom-sidebars/

  2. WPMU DEV
    Member
    Plugin Contributor

    Posted 9 months ago #

    Hi @dooleymark,

    I hope you are well today and thank you for your question.

    Yes, I did set select the Sidebar I edited that post -- because my Homepage is a post.

    Now, earlier on, I deleted a piece of code for the posts on my Homepage not to display post metadata. Is that by any chance what is preventing my Sidebar from showing up?

    Yes it might caused the issue.

    Could you please tell me what code you have edited and how you are settings post on Homepage?

    Have you used any custom code to display post on home page?
    If yes then please refer me the code so that i can troubleshoot it.

    Also, I noticed that when I edit the post to add the sidebar, on the bottom right corner when choose the sidebar, it doesn't say "main sidebar" to be replaced, but only "secondary widget area." Is that a clue to what is not working?

    You should select "Main widget area" and "Secondary widget area" in the Replaceable Sidebars list box from the following path then you can select the "Main widget area" for the homepage post.

    Admin area -> Appearance -> Custom Sidebars -> Custom Sidebars tab -> Replaceable Sidebars

    Kind Regards,
    WPMU DEV

  3. David
    WPMU DEV Support Staff
    Posted 8 months ago #

    Hey there @dooleymark,

    I hope you're well today! :)

    This thread's been marked as resolved as we haven't heard back from you in a moment. However, we'd love to get it sorted if the issue persists with the latest version.

    Just let us know if you have any further trouble with that. We'll gladly assist! :)

    Cheers,
    David

  4. dooleymark
    Member
    Posted 8 months ago #

    Thank you so much for checking in David. Strangely, I did not see your previous reply in my email. Anyway, yes, I did manage to insert a sidebar on my homepage. Thank you!

    Tonight, I posted a question about inserting 'More' into a page. I don't know if you have seen it. I have tried to do it but nothing happens on the published page!

    Many thanks in advance again.

  5. David
    WPMU DEV Support Staff
    Posted 8 months ago #

    Hi there @dooleymark,

    Oh very cool, glad that's now working for you. The plugin's just seen a major update so it works a bit differently now (it's quite intuitive really). Just let us know if you have any questions regarding it.

    I've also found that other topic of yours and added a bit there:
    http://wordpress.org/support/topic/cant-insert-read-more-link-on-page

    Hope you have a great day! :)

Reply

You must log in to post.

About this Plugin

About this Topic