Sidebar moving to the bottom of individual posts (3 posts)

  1. erstories
    Posted 6 years ago #

    I have read many threads on people having this problem have not been able to apply their solutions to mine. I deleted some ad code from my single/php file and accidentally took some other important code with it. I no longer could see the post content or the picture. I redownloaded the theme (Xmark) and restored the original single/php code. Now the content and pic are back but the sidebar moves to the bottom of the individual posts but is fine on the main home page. I am sure it is something with the code I lost - because before I screwed with it, it was fine. What could be missing or needs to be changed?

    Here is my code from the single.php page
    <?php get_header(); ?>

    <?php $showauthor = xmark_showauthor(); $dateformat = xmark_dateformat(); ?>

    <div id="left">

    <div id="lside">

    <div id="blogc" class="blogc">

    <?php if (have_posts()) : ?>

    <?php while (have_posts()) : the_post(); ?>

    <div class="date"><?php if ($dateformat == 'default') {the_time(get_settings('date_format'));} else { the_time('F jS, Y');} ?> <?php _e('at'); ?> <?php the_time() ?></div>

    <h1 class="main_title">" rel="bookmark" title="Permanent Link to <?php the_title(); ?>"><?php the_title(); ?></h1>

    <div class="author"><?php if ($showauthor == 'true') {_e('» by'); echo ' '; the_author_posts_link();} ?> in: <?php the_category(','); ?><?php edit_post_link(' <small>(edit)</small>'); ?></div>

    <div class="post">

    <?php the_content(__('Continue Reading »')); ?>


    <?php the_tags(); ?>

    <div class="blog-meta"><?php if (function_exists('sharethis_button')) { sharethis_button(); } ?> <?php if(function_exists('wp_print')) { print_link(); } ?> - <?php if(function_exists('the_views')) { the_views(); } ?></div>

    <?php if (function_exists('wp_related_posts')) { ?>

    <div class="related">

    • <?php wp_related_posts(); ?>

    <?php } ?>

    <?php endwhile; ?>

    <?php comments_template(); ?>

    <?php else : ?>

    <h1 class="main_title">Not Found</h1>

    <div class="post">

    <p class="center">Sorry, but you are looking for something that isn't here.</p>

    <?php include (TEMPLATEPATH . "/search-form.php"); ?>


    <?php endif; ?>


    <?php get_sidebar(); ?>

    <?php get_footer(); ?>


  2. stvwlf
    Posted 6 years ago #


    Take a look at your page validation

    Its showing some page layout errors. These should help you track down what happened to your single.php template code. If you can't figure something out, post back.

    Unrelated - your google analytics code is in the space between where </head> ends and <body> begins - no code is allowed in that space. Google suggests putting it at the bottom of the page, in the footer in WP, just above </body>

  3. erstories
    Posted 6 years ago #

    I am sorry, I have no idea how to use that validation information. The code is exactly as I downloaded it with the exception of the Kontera ad code at the end (which was always there when everything was fine) so I am not sure how to repair all the other errors. How should I go about it? Thanks
    Also, where is the google ad code? I can't find it there. The Kontera code is just below the <?php get_footer(); ?> and before the </body>


Topic Closed

This topic has been closed to new replies.

About this Topic