WordPress.org

Support

Support » Themes and Templates » [Resolved] Sidebar link issue in IE6

[Resolved] Sidebar link issue in IE6

  • I’m working on a theme for a friend and ran into a weird problem with sidebar links (categories, archives, etc.).

    In Firefox and Netscape they work fine but in Internet Explorer the links don’t work. You can see the text for the categories and archives but you can’t click them.

    I hope that makes sense. Other links on the page work fine like post titles and footer links.

    I can’t post a link to the site on open forum but if you need to see a link to help, contact me off forum.

    If you have a suggestion just based on what I posted here, please comment.

    Thanks in advance and happy holidays!

Viewing 4 replies - 1 through 4 (of 4 total)
  • It’s not using negative margins. Looking into it more it seems to be something with absolute positioning. I’m still having issues, so any help would be great.

    Doing more poking around I found the css that is causing be issues which is:


    h1 span {
    display: block;
    text-align: right;
    margin-top: -1.5em;
    padding-right: 5px;
    }

    which makes my code go to the right. If I remove the display block, my sidebar links work in IE but then my H1 text shifts to the left and I want it to the right.

    Hope this might help someone to help me with this.

    Thanks in advance.

    OK, I got it solved. I needed to add a new span class to my style sheet.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Sidebar link issue in IE6’ is closed to new replies.