Support » Theme: Pinboard » Sidebar jumping below content

Viewing 12 replies - 1 through 12 (of 12 total)
  • Theme Author Daniel Tara

    (@pseudoxiah)

    Under Theme Options > Layout for the option Layout Columns try selecting 3.

    HI Daniel – thanks for getting back to me so quickly. Currently it is selected as 3 columns.

    paul.a.cunn

    (@paulacunngmailcom)

    I think this can happen if your trying to put something in the side bar that is wider than 1/3 of your page. If you have it set to 3 columns then your side bar can really be only 1/3 of the width and the “content area will take up 2/3 of your page. If you want your sidebar to be wider try using the following code, make sure they both add to 100%. You can mess with percents as needed. Alternatively you could reduce the size of whatever you are trying to put in your sidebar.

    #content {
    	width: 50%;
    }
    
    #sidebar {
    	width: 50%;
    }

    Hope this helps,

    Cheers!

    Alexander

    (@alexanderbepunkt)

    Looks like the problem is that the css was tweaked with the sidebar width by setting twocol to 50%.

    If you choose a 2/3 column layout than the sidebar shouldn’t exceed 33%.

    Thanks for your input Paul, but I am actually wanting a 2/3 layout and what is strange to me is, the sidebar is incorrect on all pages – except if you click onto one of the posts, then the layout corrects itself.

    Alexander, I have taken a look at the CSS and I have found the following:
    Under Grid System I have
    .twocol {
    width:50%;
    }

    .threecol {
    width:33.3%;

    I am assuming this is correct….. is it?

    Or is there somewhere else I should be looking? I’m not that good with CSS, and only have basic CSS knowledge.

    Is there not some code I could add into the Custom Code under Layout that could override what is there currently?

    Thank you both for getting back to me!

    [Moderator note: You can receive urgent support at http://jobs.wordpress.net ]

    Alexander

    (@alexanderbepunkt)

    There is a straight forward step-by-step strategy to find the problem:

      1) Remove your personal css definitions
      2) Remove all widgets
      3) Deactivate all plugins
      4) Build changed code back

      5) At least: reinstall the theme using the dashboard

    Try each step one-by-one and see if the problem persists.

    Hi Daniel and Alexander

    I found the problem. I had content / sidebar selected under layout and on each page. I deselected it and selected default template on the pages and it has resolved my issues.

    Thanks for your input.
    Lisa

    Lisa, for me this worked out as well.

    But do you know if I can only change the homepage to “Full Width” even though when the default template is Content / Sidebar?

    Moderator Andrew Nevins

    (@anevins)

    @Proponk, can you ask that on your own thread?

    okay!

    This can be fixed very easily, it is only width problem, use inspect element in firefox or chrome and adjust the width then try to change side bar setting in theme editor.

    WPyogi

    (@wpyogi)

    Forum Moderator

    @azharmuhd – this thread is 9 months out of date and already marked resolved. If you want to help out, please stick with threads that are current and/or not already resolved.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Sidebar jumping below content’ is closed to new replies.