Support » Theme: Founder » Sidebar doesn’t work after last WordPress update

  • Resolved RatBikeNacho

    (@ratbike)


    Hello there.

    I don’t know why my sidebar doesn’t work after the WordPress 5.7 update. Anyone with the same issue?

    Thanks and greetings!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Theme Author Ben Sibley

    (@bensibley)

    Thanks for using Founder!

    It looks like all the Javascript functionality from Founder and plugins on the site is failing: https://share.getcloudapp.com/DOuDjo0B

    The issue is that they all need the jQuery script, which isn’t currently loading. I would turn off the option you have enabled to load jQuery externally so that it can be loaded normally from your site, and that should resolve all of these issues at once.

    Thread Starter RatBikeNacho

    (@ratbike)

    Hello Ben.

    Thanks for your quick reply. I can’t see the image you posted, it’s eternally loading … But it doesn’t wrong.

    I did it as you suggested using the Google CDN.

    For anybody: In my ‘functions.php’ I added this block …

    // Google’s CDN jQuery instead of local jQuery libs
    add_action(‘wp_enqueue_scripts’, ‘mytheme_enqueue_scripts’);
    function mytheme_enqueue_scripts() {
    wp_deregister_script(‘jquery’);
    wp_register_script(‘jquery’, (“https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js”), false, ‘1.7.1’);
    wp_enqueue_script(‘jquery’);
    }

    … and it works again 🙂

    • This reply was modified 1 month, 1 week ago by RatBikeNacho.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.