WordPress.org

Forums

[closed] Sidebar disappeared... (17 posts)

  1. trailsnet
    Member
    Posted 3 years ago #

    On my trailsnet website, the sidebar disappeared and then reappeared at the bottom of the page in the main (left/widest) column. This is true of not only the home/blog page, but also all the child pages, trail pages, etc. I am using the Graphene theme and have tried every trick I know to get the sidebar back where it belongs but to no avail.

    Any and all help/tips/suggestions will be greatly appreciated.

  2. alchymyth
    Forum Moderator
    Posted 3 years ago #

    somehow, the width information for the sidebar might have gone lost;

    try to add this to the bottom of style.css of the child theme:

    .sidebar{width:290px;}

    (or try to upload a new copy of style.css of the theme)

    totally unrelated:
    a nice rail-trail in the 'old world' is the Bristol and Bath railway path

  3. ramlal.tr
    Member
    Posted 3 years ago #

    you put this in ur style sheet line no 1983
    #sidebar1, #sidebar2 {
    display: inline;
    float: left;
    margin-top: 4px;
    padding-bottom: 30px;
    width: 290px;
    }

  4. Roselienjessie
    Member
    Posted 3 years ago #

    If you scroll all the way down to the bottom of the page, you'll find the sidebar content. It looks like the category span at the bottom of each post is too wide and is pushing your sidebar content to the bottom. Try changing the width of .category in your style.css

  5. trailsnet
    Member
    Posted 3 years ago #

    Thank you for all your help. It sounds like the first thing I should do is make sure the sidebar width is 290px.

    Now my true ignorance will shine through. I have no idea how to change/add coding on a WordPress theme. I just browsed through every possible setting I could find on my dashboard and don't see an option for viewing and editing code.

    I would greatly appreciate some quick advice on what to look for.

    Thanks for the help and thanks to alchymyth The Sweeper for the great rail-trail advice. Sometime in the next couple years I plan to ride every lengthy bike path in England. I love that place.

  6. alchymyth
    Forum Moderator
    Posted 3 years ago #

    http://codex.wordpress.org/Editing_Files

    i.e.
    dashboard - appearance - editor: style.css is usually already selected; if not, select from the list on the right.

  7. trailsnet
    Member
    Posted 3 years ago #

    That's incredible. It actually worked. You are a complete genius!!!

    Thank you so much for the code, the mini tutorial on finding the editor and, once again, for the trail information, alchymyth!! You went above & beyond. I appreciate it.

    Now all my trailsnet pages work except the trail description pages. A developer created special child pages just for the purpose of displaying the trail information entered by me and others. I tried adding the .sidebar{width:290px;} code at the bottom of the child page style.css page, but it didn't work.

    You've already been incredibly helpful, but if you happen to have another solution up your sleeve for this problem, I'd appreciate it.

    Thanks again!!!

  8. alchymyth
    Forum Moderator
    Posted 3 years ago #

    adding this to style.css of the shild theme seems to help:

    <style>.single #content-main{max-width:610px;}</style>

  9. trailsnet
    Member
    Posted 3 years ago #

    alchymyth
    The Sweeper

    Thanks again for your help. Unfortunately, I couldn't get it to work. I even tried adjusting the max-width value a few times to see if that made a difference, but no luck.

    It's nice to have the rest of the site running properly, but so far the Trails pages have no sidebar.

  10. kjodle
    Member
    Posted 3 years ago #

    Did you see the response I gave you in the Graphene support forum?

    If you edit theme files, your changes will be lost at the next update. Graphene 1.8 will be out soon, so you'll have to make these changes all over again.

  11. trailsnet
    Member
    Posted 3 years ago #

    kjodle - Yep, I saw your response, and thanks for that. You're absolutely right about losing the change each time Graphene is updated. However, this is just a temporary fix until I can sit down w/ my WP guru and make a permanent change.

    I wish I could make some of the changes myself, but unless they are really clearly explained to me like alchymyth did above, I am totally lost when people start talking in code.

    I'm a complete css/coding dunce. However, I welcome any and all explanations and solutions and am grateful for each one.

  12. kjodle
    Member
    Posted 3 years ago #

    You don't need any code to resolve this issue. Just don't enter numbers in the boxes in Graphene's Column Width control pane. Leave them empty and use the sliders instead. Graphene will automatically adjust for the padding around the various theme elements.

  13. trailsnet
    Member
    Posted 3 years ago #

    Okay, I see what you mean now. I just checked out the column width options and, sure enough, there are numbers in every one of the boxes. I also noticed that there are numbers in the three column option even though my website only has two columns. In fact the only slider bare that seems to currently be enabled is the three column one.

    So should I go in and delete all those numbers and then start using the two column slider?

    Thanks for your assistance, BTW.

  14. kjodle
    Member
    Posted 3 years ago #

    Just empty out the numbers in the width boxes and use the sliders only.

  15. onedad1kid
    Member
    Posted 2 years ago #

    I just updated to 1.8 and now am having a similar problem. I've tried adjusting the width in the CSS file (and have tried a variety of numbers including the width mentioned in this thread by others), wiping out the numbers in the column width options, etc., and nothing fixes this. At first I thought it was Disqus, but I disabled and am still having the problem. Here's an example: http://1dad1kid.com/2012/08/10/living-in-a-culture-of-fear/

  16. silverks
    Member
    Posted 2 years ago #

    Your second pinterest image (the comic) has additional closing </div> that's causing the issue. Try removing that image completely to see if the layout returns to normal.

  17. onedad1kid
    Member
    Posted 2 years ago #

    That was created by a plugin. I deactivated the plugin, and the problem is gone. Any ideas on how I can edit that in the plugin editor?

    Thanks so much!!

Topic Closed

This topic has been closed to new replies.

About this Topic