WordPress.org

Support

Support » How-To and Troubleshooting » Sidebar 2 widget edits can’t be saved–Missing “Save Changes” button

Sidebar 2 widget edits can’t be saved–Missing “Save Changes” button

  • The title pretty much says it:

    I’m trying to modify the Page widget, which is in Sidebar 2. Now I make the modification I want, but there is no “Save Changes” button.

    How did I get them in there in the first place? You might ask… It was created in an earlier version, and on upgrade, (which I expected would be the case) the widgets were there, where I had put them, etc.)

    I tried it in Firefox, Opera, Sea Monkey, and the “Save Changes” button doesn’t appear under the widgets, which I what the system says I should press to save, before I leave the page.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Cathy Tibbles

    @multitalentedmommy

    Has it been working properly since the upgrade? If not, I would re-upload the upgrade files… it is my guess that something wasn’t uploaded properly, or you don’t have permission to make changes to the sidebar. Are you logged in as the admin?

    The functionality was lost after the upgrade. The button no longer shows.

    I’ve been doing this type of thing for a long time; no error in upload. Also, if there was something wrong of that type, then, it would most likely a single file with the appropriate script… and perhaps a reference graphic.

    The folks that worked on this will know which PHP file contains the information to show the button as it did before. It would take me quite a while to find and edit the file.

    I have the same problem.
    I’m working with WordPress 2.7.1. / IE 6.0.0 & Firefox 3.0.9
    The Save button only available when i select “Current Widgets” >> Footer >> Show
    this is a strange behavior! Now i can’t make any changes in the sidebar 1.

    I’m stuck

    Multitalentedmommy,

    I have all the correct permissions. If I didn’t, then I wouldn’t be able to make changes in sidebar1, which I can, and they can be saved.

    I have the same problem with a new WordPress install I am hosting on 1and1.com. The button is missing no matter what theme I choose. It is not computer or browser related. I see the save button when going into my existing blog hosted on lunarpages.com.

    Running WP 2.7.1.

    Also notice that the Dashboard page is missing the WordPress news and WordPress development section even though it’s checked.

    Found the problem. It’s cause by the plugin Google Analyticator. Deactivating it will restore the save button in widget and restore the content on the dashboard page.

    http://plugins.spiralwebconsulting.com/analyticator.html

    patyuen have you updated to the latest version?

    We recently put out a fix for the problem you were referencing so that the widget will not even appear at all if cURL is not enabled on your server. If you are still experiencing this issue in the latest version, please let us know.

    Found a workarround of this problem WP 2.7.1:

    Deactive all of your “Plugins” in the “Plugins”
    then go to de the Widget page.
    The save button is now visible

    After saving your mods on the widgets page you can active the plugins again.
    Maybe there is an another solution for this problem but this works fine!

    Hopefully this workaround helps other people.

    @ humann71: You don’t have to deactivate all your plug ins. Only the Google Analyticator plugin.

    @ spiralwebconsulting: It was the latest version 4.0.1. I am installing this in a client’s site which is hosted on 1and1.com. I don’t know if Curl is activated or even an option. I searched their FAQ and the only occurrence of Curl is a reference to Libcurl 7.10.3 in the php section.

    I suggest you don’t implement any code that will break a core function of WordPress. At the minimum, you should do some kind of check to see if Curl is installed or give a warning this will break the widget function.

    Hello Patyuen,

    Thanks for given another solution but i have not installed a plugin of “Google Analyticator”.
    Maybe you can tell me where i’can find the plugin of “Google Analyticator” in the dashboard..

    But after activate the plugins again the problem is not comming back.
    Below is a list of my installed plugins:

    Exec PHP
    Flickr + Highslide
    NextGEN Gallery
    Photos Flickr
    Smart Youtube
    Twitter for WordPress

    Hopefully it can help you to find a solution for this strange behaviour

    @ hamannn71: I don’t have any of those plugins. So this tells me one of your plugins is also causing the problem. If you deactivate your plugins one at a time, you can help others isolate which one is causing the problem.

    Thanks Patyuen,
    Been trying to figure out why I cant save widget config for 2 hours in new 2.7.1. Finally did a search and came across your post 1st. Yep, 1&1 is my host and undoing Goog analytics fixes the issue.

    Hello patyuen,

    Found the problem:
    It seems that deactivate-activate “Twitter for WordPress” wil disapearing the save button again!

    Thanks for advise.

    I am into v 2.8.4 and have this same problem. I deactivated and activated plugins one at time. The save button has not re-appeared but the additions and changes I made “saved magically”.

    Have any developers looked at this problem for a fix?

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Sidebar 2 widget edits can’t be saved–Missing “Save Changes” button’ is closed to new replies.
Skip to toolbar