Support » Plugin: WP Photo Album Plus » Side-effect on translations in 7.4.0

  • Resolved serge-wp

    (@serge-wp)


    Hi Jacob,

    A slight glitch has slipped into the latest version 7.4.00.005 re translations:
    The custom data field NAMES now show the language specifiers and the full content of the field names, but no longer switch to the selected language.
    IX A-17 (and even IX A-18) are ticked, but all custom fieldnames both in the mouse fly-out in thumbnails and in the description box under the images show the full contents of the custom names, e.g. “[:en]English name[:de]Deutscher Name [:fr]Nom Français[:]” instead of switching over to the selected language and showing only that language.

    I also concurrently upgraded WP to 5.4.2, which may have compounded the issue…

    serge

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Thanx for the report. Will be fixed asap. You can patch it:
    file wppa-items.php, line 478:
    change :

    $cap = wppa_opt( 'custom_caption_'.$i ); // Caption

    into:

    $cap = __( wppa_opt( 'custom_caption_'.$i ) ); // Caption

    (i,e, put __() around the function )

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    This has been hotfixed. De-activate and delete the plugin, then install again as if it is a new plugin. You will loose no data or settings.

    Thread Starter serge-wp

    (@serge-wp)

    Excellent! Many thanks for the quick fix and for the DIY option. I overslept and only saw the latter together with the hotfix [which was then easier], but I much appreciate the lifeline!

    Oh, and of course: Solved 🙂

    Many Thanks,
    serge

    Thread Starter serge-wp

    (@serge-wp)

    PS: Just realised that you also removed the blank custom fields from view.
    Very nice!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Side-effect on translations in 7.4.0’ is closed to new replies.