Support » Plugin: Shibboleth » Sibboleth installation internal server error

  • Resolved blackg96

    (@blackg96)


    Hi, every time I install shibboleth wordpress it doesn’t work anymore. It tells me 500 internal server error, how can I fix it?

    Preview

    • This topic was modified 4 months, 1 week ago by blackg96.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi,

    Did you configure a SP on that server?

    All the best

    I can’t do it because even the control panel doesn’t work, always the same error

    First you have to configure a Service Provider on the Webserver itself. That is not a WP thing. Please read the FAQ of the plugin.

    Try to delete the two Auth lines in the .htaccess:

    AuthType shibboleth
    Require shibboleth

    Plugin Contributor Jonathan Champ

    (@jrchamp)

    Thanks @absolutinternet for addressing this so quickly. Indeed, if installing this plugin causes a 500 error, it is almost definitely because your httpd configuration does not have “AuthType shibboleth” support.

    It might be good for us to modify the plugin so that it wraps the configuration in an IfModule block, such as:

    <IfModule mod_shib>
        AuthType shibboleth
        require shibboleth
    </IfModule>

    If installing the Shibboleth module, removing the Auth lines from the .htaccess or modifiying the block in the .htaccess to add the IfModule does not allow you to access the site, please feel free to reopen this topic. For now, I’ll mark it as resolved.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.