Permalink Finder Plugin
Shows "This webpage has a redirect loop" error for some page (5 posts)

  1. UiPoka
    Posted 1 year ago #

    I have just moved my blog from blogger to wordpress and this permalink finder plugin was a live saves. It works for most of the links but some of the links are not working and they shows this "This webpage has a redirect loop" in the browser. My site permalink is are mysite.com/how-to-change-engine-oil-at-home/ but links which doesn't works looks like this mysite.com/how-to-change-engine-oil-at-home/?m=1 if I remove the ?m=1 and try the link again it comes. Can you please tell me what do to now? How to fix this? I am losing traffic. :(


  2. kpgraham
    Plugin Author

    Posted 1 year ago #

    ?m=1 is a WordPress query variable. The permalink finder only works with permalinks. You have to change your permalink structure to something other than the default on the settings menu/permalinks.

    The plugin is looking for a way to get to a post that matches ?m=1 and failing miserably.

    If you don't want to use the WordPress custom URL structure you should uninstall the plugin.


  3. UiPoka
    Posted 1 year ago #

    Thank you for your response. Sorry for taking long time to respond. I still have the same problem. My Permalink setting is http://www.domain.com/sample-post/ still when my traffic comes from google search engine they get error "This webpage has a redirect loop" Now google website gave me 1000 error this morning and when I tried to manually fetch any link it gave me this error

    HTTP/1.1 301 Moved Permanently
    Server: cloudflare-nginx
    Date: Thu, 03 Jul 2014 07:31:01 GMT
    Content-Type: text/html; charset=UTF-8
    Transfer-Encoding: chunked
    Connection: keep-alive
    Set-Cookie: __cfduid=d9e48b606ac31edda5c6ae8bf8904957d1404372659885; expires=Mon, 23-Dec-2019 23:50:00 GMT; path=/; domain=.domain.com; HttpOnly
    X-Pingback: http://www.domain.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache
    Set-Cookie: mc_session_ids[default]=dc2222e2dd3f8c7f071a6231fb39c53e41154ef5; expires=Thu, 03-Jul-2014 07:36:00 GMT; path=/; httponly
    Set-Cookie: mc_session_ids[multi][0]=20033dc4058d9db9f43ede1b821086bb6fccbc2d; expires=Thu, 03-Jul-2014 07:36:00 GMT; path=/
    Set-Cookie: mc_session_ids[multi][1]=364bb191a86eef56a0689898c2608d1dd5ccbe0c; expires=Thu, 03-Jul-2014 07:36:00 GMT; path=/
    Set-Cookie: mc_session_ids[multi][2]=7eb58aed9bd3984fb609ec6699d3f2f9088d48d1; expires=Thu, 03-Jul-2014 07:36:00 GMT; path=/
    Set-Cookie: mc_session_ids[multi][3]=4dc5014cee682fcf5a62adfae05c4d14920424b1; expires=Thu, 03-Jul-2014 07:36:00 GMT; path=/
    Set-Cookie: mc_session_ids[multi][4]=19d2ee980583b8b41d1f763ebaea0ce2a71a1f5c; expires=Thu, 03-Jul-2014 07:36:00 GMT; path=/
    Set-Cookie: wfvt_3469633346=53b506b4b0f71; expires=Thu, 03-Jul-2014 08:01:00 GMT; path=/; httponly
    Vary: Accept-Encoding,User-Agent
    Location: http://www.domain.com/yamaha-r1-engine-specs-2013/?m=1
    CF-RAY: 144161844fd909ca-ORD

    Can you please tell me where is the problem and how to fix this issue ?

  4. UiPoka
    Posted 1 year ago #

    Getting this message from google webmaster tools crawl details for one post link "Google couldn't follow your URL because it redirected too many times." all of the content is there but still for most url it can't fix. In the setting its showing it fixed the link but when I click on any link from "Fixed Permalink" or "Requested Page" it gives me redirect loop.

  5. kpgraham
    Plugin Author

    Posted 1 year ago #


    Please uninstall the plugin. There is something about your permalink structure that the plugin can't handle.

    The plugin strips out non-ascii characters and converts spaces and underscores to dashes. If you rely on the url to have these characters, the plugin will not be able to find your page.

    There is a newer version at BlogsEye.com under Beta Test plugins that has some changes, but I have stopped updating the WordPress repository with new versions because the support requirements are beyond me right now.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Permalink Finder Plugin
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic