Support » Plugin: The Events Calendar Shortcode & Block » Shows “at” after the timestamp of the event

  • Hi, I’m using the latest version (1.7.2 with WP 4.9.1) and I noticed that it shows “at” after the date and time, regardless if it’s an event with time or all day:

    21 December (Thursday) às 08:00 – 17:00 at
    20 December (Wednesday) às 08:00 – 29 December (Friday) às 17:00 at

    Is there a way to prevent this from happening?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Brian Hogg

    (@brianhogg)

    Hi @lfreitas!

    The “at” is likely coming from the venue. Normally you would see (date time details) at (venue name) but for whatever reason that’s blank.

    Can you try adding venue='false' to the shortcode and see if that does the trick? ie.

    [ecs-list-events venue='false']

    Hi @brianhogg!

    Thanks for the quick reply.

    It worked.
    But I need to show the venue… my current shortcode is:

    [ecs-list-events limit='6' venue='true' contentorder='date_thumb, title, date,venue']

    And not all events have venues (like holidays).

    Also, I use this website in Brazilian Portuguese and the separator between hours and the venue is the same that is used before time and in this language it looks wrong, because I would use different words (unlike “at” in English):

    21 dezembro (quinta-feira) às 08:00 – 17:00 às Prédio 10

    It should be something like:

    21 dezembro (quinta-feira) às 08:00 – 17:00 em Prédio 10

    I’m testing the current version of the plugin in a development environment but in the production I use version 1.2 with a fix to show the date thumbnail (it was and old topic here).
    In my current code the venue is shown in the second line, without any word before it.

    Is it possible to add to a next version something that would provide some flexibity regarding the separator before venue? Or some more personalization in the display?

    Aside form that, thanks for the plugin!

    Plugin Author Brian Hogg

    (@brianhogg)

    Hi @lfreitas!

    The “at” appearing at the end even if there is no venue is something I’ll look to fix in the next release.

    The display of the time should be a setting within The Events Calendar itself (under Events then Settings, scroll down to “Date Format Settings”). One of the options should let you change the wording?

    As a note the pro version does give you the ability to create a custom template without hacking the plugin so you can upgrade from the old version.

    Hi @brianhogg!

    The “at” appearing at the end even if there is no venue is something I’ll look to fix in the next release.

    – Thanks!

    The display of the time should be a setting within The Events Calendar itself (under Events then Settings, scroll down to “Date Format Settings”). One of the options should let you change the wording?

    – Yeah, but the plugin uses the date/time separator in the venue as well so in Portuguese it doesn’t fit well.

    – I understand that maybe you are limited here by the TEC plugin since you get their information, but I’ll just let it registered that using date/time separator in the venue section isn’t always the best solution.

    As a note the pro version does give you the ability to create a custom template without hacking the plugin so you can upgrade from the old version.

    – Thanks for the info. Unfortunately in this case I won’t be able to buy but will consider in other situations.

    EDIT: marking as resolved because of the first answer/quote.

    Plugin Author Brian Hogg

    (@brianhogg)

    Hi @lfreitas!

    For the translation of “at” you can try suggesting a different translation, looks like it is on this page:

    https://translate.wordpress.org/projects/wp-plugins/the-events-calendar-shortcode/stable/pt-br/default?page=2

    And also look for a similar string with The Events Calendar (not sure which page this is on). There are filters available to change it in your code if you know a bit of PHP (for example the ecs_event_venue_at_text filter to change the “at” before the venue).

    If you update to version 1.7.3 when it becomes available this should hide the “at” for you if there is no venue for an event.

    Thanks!

    Thanks, @brianhogg

    I’ll try the things you suggested!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Shows “at” after the timestamp of the event’ is closed to new replies.