Support » Theme: Storefront » “Showing X results” problem

  • Resolved noritarte

    (@noritarte)


    In the mobile version of my site there is a problem that I can’t solve, visible here:

    https://snipboard.io/HetwKp.jpg

    The element “Shopping x results” next to the product filter dropdown menu ends up on the footer.

    I tried to hide the dropdown filter menu with all the css and php found online but it doesn’t work. Do you know if there is a way to delete the dropdown menu below? Or at least to distance it from the footer. Thanks

Viewing 8 replies - 1 through 8 (of 8 total)
  • You have the following in your custom CSS which I think I may have given you in the past for an issue you made a thread about

    @media screen and (max-width: 768px) {
    .site-footer {margin-top: -55px;}
    }

    If you remove that, it should create enough space to show the content for that area.

    Thread Starter noritarte

    (@noritarte)

    I eliminated that css but the problem remained the same. And I wouldn’t want to create too much empty space above the footer.

    I would have found another solution that works to eliminate the results count and solve the problem in this way (I tried them all but this is the only one that works):

    /* CSS that Removes All Showing Results */
    p.woocommerce-result-count {
    display: none;
    }

    The problem is that it works on desktop but not on mobile, how is that possible? See example here:

    https://www.noritarte.it/book-author/luigi-ghirri/

    I removed the negative margin from that code and I get this which looks correct to me in mobile

    https://i.snipboard.io/hw0qmF.jpg

    If you don’t want it displaying on mobile you can use the following

    @media screen and (max-width: 768px ) {
        .site-main .storefront-sorting:last-child {
            display: none;
        }
    }
    Thread Starter noritarte

    (@noritarte)

    I think there’s a conflict in my css file, because:

    1) if I change the values of this css nothing happens:
    @media screen and (max-width: 768px) {
    .site-footer {margin-top: -55px;}
    }

    2) If I add this css I see the counter disappear in the preview on the wordpress panel but if I go to the site with my iphone the counter is still there.

    @media screen and (max-width: 768px )
    {
    .site-main .storefront-sorting:last-child {
    display: none;
    }
    }

    And yet there are no errors in the CSS, I don’t understand…

    Which CSS file are you referring to? The CSS for the site-footer class is set in Appearance->Customize->Additional CSS

    If you are making changes there and nothing is changing, you may want to try to look into any error logs on the server to see what may be happening.

    Thread Starter noritarte

    (@noritarte)

    I found the problem: it was a plugin called wp fastest cache. On some pages I could see the old cache without the changes even deleting the Safari browser cache from my iphone. Now I disabled the plugin and I can see everything correctly. Thanks for the support.

    Glad to hear you were able to get it figured out. You can probably reactivate that plugin. Caching isn’t necessarily a bad thing, just have to remember to always clear it out when making changes if you don’t see things being updated.

    Thread Starter noritarte

    (@noritarte)

    Thanks, I’ll try to do it.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘“Showing X results” problem’ is closed to new replies.