• Resolved Purnendu

    (@impurnendu)


    I enabled Flat 50 discount for a payment gateway. (I put -50, fixed).
    It is showing rightly on product page, but while checkout it is showing 51.50. What is the issue?

    Tax is disabled.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi @impurnendu,

    Thank you for raising the issue which you are facing on your site.

    I have tried to replicate the issue on our staging site and I have observed that the discount set is calculated fine on the checkout page as well.

    I am attaching a screenshot for your reference: https://prnt.sc/nn6zn8

    Can you please share the screenshots of the settings which are set on your site on the ticket which we have created for you? This information would help us to replicate the issue on our end and then I can get back to you with an update.

    Regards,
    Komal Maru

    Your support is too much delayed and you are not interested in your customer satisfaction.

    Hi @impurnendu,

    I apologize for the delay in response. I was occupied with some other task.

    Thank you for providing us the settings which you have set in the Payment method.

    Can you please let me know whether you have set any Global Extra fee or in the additional Fee section?

    I am attaching screenshots of your reference: https://prnt.sc/npb4a1 , https://prnt.sc/npb4io

    Because those fees will also be included in the fee which you have set for the payment gateway.

    It would be great if you can share the screenshots of all the settings which are set in our plugin.

    Regards,
    Komal Maru

    No there is no extra value or global fees I set. There is an another problem I found recently.

    If I set “Maximum fees”, it is also not working for negative fees!!!

    Hi @impurnendu,

    I have checked with ‘Maximum fee value’ option as well, it is working fine with the negative fees. I am attaching screenshots for your reference: https://prnt.sc/npun19 , https://prnt.sc/npun9o

    In our plugin, when ‘Fee value’ is set along with ‘Maximum fee value’ option provided it is not set to ‘0’ and if ‘Fee value’ is greater than ‘Maximum fee value’ then the customers will be charged Maximum fee value respectively.

    So, please follow the below rule for fees which will be charged to the customers.

    1) Fee value > Maximum fee value, the fee will be Maximum fee value.

    I hope this clarifies your query for the Maximum fee value setting.

    Regards,
    Komal Maru

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘SHOWING WRONG FEES’ is closed to new replies.