Support » Plugin: Better Plugin Compatibility Control » Showing support for minor WP versions

  • Resolved GermanKiwi

    (@germankiwi)


    Hi, I’ve been using this plugin for ages and find it really helpful. I have a request though:

    It would be great if BPCC could take account of sub-versions of WordPress, and not show them in red if a plugin doesn’t specifically mention the current sub-version of WordPress.

    Example: let’s say I have a plugin installed called “Acme Plugin”, and its readme file says it supports WP versions 3.5 – 3.8. However, I’m running WordPress 3.8.1 on my site.

    As of right now, BPCC will show the “3.8” text in red because it doesn’t exactly match the version of WordPress (3.8.1) that I’m using. However, in reality, it’s quite safe to assume that if a plugin supports 3.8, it will also support 3.8.1 (and 3.8.2 etc) as well.

    For that reason it would be nice for BPCC not to show the “3.8” in red, but to show it in green because it really is still supported. (In fact this might even be official policy from the WordPress developers, that if a plugin supports a major version, it’s assumed to support all minor versions too? Is that correct?)

    What do you think?

    https://wordpress.org/plugins/better-plugin-compatibility-control/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author wpseek

    (@alphawolf)

    Hey GermanKiwi,

    you have a valid point there. 🙂 Going to implement this right away.

    Awesome, thanks! 🙂

    Plugin Author wpseek

    (@alphawolf)

    Just released version 3.8.1.10 that includes your proposed change! 🙂

    ps. Das ist deutscher Text, den die Mods nicht verstehen. Muahahaha.

    Danke – die neue Version funktioniert gut!

    Warum mussen die Mods nicht uns verstehen?! 🙂

    I found a couple of exceptions that might still need fixing:

    1) One of my installed plugins claims to support up to version “3.8-rc-1” and this version is still in red text. Can you support this format too?

    Also, will BPCC support showing these formats now in green text?…

    3.8beta3
    3.8-RC2
    3.8b3

    (I’ve seen plugins that use this kind of formatting with older versions, such as 3.6b3 or 3.6-RC2, which are still correctly shown in red text like they should be, but I wonder what would happen if they were based on 3.8 rather than 3.6 – would BPCC understand that?)

    2) Another plugin supports “3.8.0–3.8.1” and the first version mentioned there (3.8.0) is still in red, not green. 🙂

    Cheers!

    Plugin Author wpseek

    (@alphawolf)

    Hey GermanKiwi,

    that actually works for me.

    Do you happen to use german locale on your server? I’m actually using floatval() to get float from a value, so giving “3.8.10”, it returns 3.8 (as this is a valid float value).

    On german (or other EU countries’) environments a comma is expected for floats, so it expects 3,8 but gets 3.8, which might cause the problem for you.

    ps. Thought you were german because of your name, sorry. 🙂

    I’m not sure where or how to check the locale that you’re referring to – do you mean some setting in WP, or in Apache? My website is hosted in Germany.

    Unfortunately I don’t know anything about floatval. In any case, are you saying that this is something you can fix? (Assuming this is a problem of some kind?) I’m not sure actually if you’re explaining a problem to me, or just letting me know how the plugin works! 😉

    Ich wohne in Deutschland, aber ich bin Kiwi. 🙂

    Plugin Author wpseek

    (@alphawolf)

    Sorry, didn’t mean to confuse you. I was just thinking out loud. 🙂

    Regarding the locale: Are you running WP with german language (do you have specified ‘de_DE’ for WP_LANG in the wp-config.php file? If that doesn’t say anything to you, you probably run WP in english.

    I’m just trying to figure out what might be causing the issue for you as it’s working for me.

    My WPLANG is blank, which I believe means it defaults to English. It looks like this in my wp-config.php:

    define('WPLANG', '');

    Can you clarify what exactly is working for you (from the examples I gave in my previous post), that is not working for me? Was it the example of “3.8-rc-1” or one of the other examples I gave?

    Plugin Author wpseek

    (@alphawolf)

    Well, all of your examples work for me. 🙂

    I’m trying to create a new version for you to test as I’m still not sure why it’s not working for you.

    Okay. Well just to clarify, of the examples I mentioned above, only these two were specifically not working for me:

    3.8-rc-1
    3.8.0–3.8.1 (“3.8.0” is red but “3.8.1” is green)

    The other ones I mentioned were just a question for you, to ask *if* BPCC would understand them and show them in green – I don’t actually have these on my own Plugin page:

    3.8beta3
    3.8-RC2
    3.8b3

    🙂

    Plugin Author wpseek

    (@alphawolf)

    Hi GermanKiwi,

    sorry for the delay, but have been busy days.

    Well, BPCC would understand the ones you mentioned, but I will test each and one of them. 🙂 I’ll also have a look at 3.8-rc-1 and 3.8.0–3.8.1. The latter seems weird to me.. doesn’t seem to be a valid stable tag.

    Can you name the plugin that has 3.8.0–3.8.1 for its compatiblity info? Looks weird. 🙂

    Thanks!

    Well let me clarify what I meant with “3.8.0–3.8.1”.

    As you know, BPCC adds two version numbers for every plugin, to the Plugins page. The first number is the minimum version support, and the second number is the latest version support. These two numbers are taken (by BPCC) from each plugin’s readme.txt file. They are displayed on the Plugin page with a dash “-” between the numbers.

    So the plugin I’m referring to is Simple History. There’s nothing unusual about its version support. Its readme.txt file says this:

    Requires at least: 3.8.0
    Tested up to: 3.8.1

    And that is a perfectly correct version statement, right? So this is displayed on the Plugin page as “3.8.0-3.8.1”, just like every other plugin shows the two version numbers.

    But in the case of Simple History, it shows the first version number “3.8.0” in red text, and the second version number “3.8.1” in green text.

    Hope that helps! 🙂

    Plugin Author wpseek

    (@alphawolf)

    Ah, alright.

    I thought with “3.8.0-3.8.1” you were referring to a plugin’s version info for one (min or max) stable tag. But you were obviously referring to the output BPCC generates. 🙂

    I’ll have a look at the “Simple History” plugin, thanks!

    edit. Okay, will be fixed in the next plugin update. 🙂 Here’s the current update for the plugin, feel free to test if everything is working as expected for you: https://gist.github.com/AlphawolfWMP/9642792

    Yeah, exactly – glad we’re on the same page now! 🙂

    Okay I just updated to 3.8.1.15 but unfortunately the Simple History plugin still shows the first version number in red – you can see it in the middle of this screenshot.

    I don’t think it’s the fault of that plugin though – I suspect it’s because the “Requires at least” field, from the readme file, gives 3.8.0 which is the current major version that I’m using. I think BPCC is tripping up on that somehow. The Simple History plugin is the only plugin I have, that has a “Requres at least” value of 3.8.0. All the other plugins give older versions of WordPress for their “Requires at least” field.

    Can you replicate this still?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Showing support for minor WP versions’ is closed to new replies.