Support » Plugin: Better Click To Tweet » Showing plain URL instead of post name

  • Resolved thecornerofexcellence

    (@thecornerofexcellence)


    Hi there!
    I’ve noticed that recently when someone shares a post through Click to Tweet, the plain URL of the post shows like this although my permalinks are set to “post name”.

    Communicating assertively is key to a healthy relationship with ourselves & others. Reasons for not being #assertive & practicing #assertiveness. #AssertiveCommunication https://www.thecornerofexcellence.com/?p=17474 a través de @XcellenceCorner

    Activating the short URL option in Click to Tweet also does not work anymore. I think it used to catch that from Jetpack which I do not have activated anymore.

    How can I fix it so that the entire URL with the post name shows?

    Thank you

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Ben Meredith

    (@benmeredithgmailcom)

    Hi @thecornerofexcellence

    Happy to clarify, here!

    That plain permalink is displaying because you’re using the Shortlink option within the Better Click To Tweet settings.

    When you had Jetpack installed, it used the jetpack shortlink, now it’s just using the plain permalink. It’s compatible with several URL shortener service plugins (including Jetpack’s) but if your site is not using one, the “shortlink” that it uses is the plain permalink.

    If you deactivate that setting, it will default back to whatever is set in the permalinks.

    ​​Let me know if that resolves things, or if you need further assistance. ​Thanks for using Better Click To Tweet! Have a great day.

    Thread Starter thecornerofexcellence

    (@thecornerofexcellence)

    Hi Ben!
    I saw that setting and deactivated it before posting here because it didn’t seem to work. Just checked and it seems to work now… Maybe I didn’t see the change become effective before due browser caching.
    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.