Support » Plugin: Events Made Easy » Showing fatal error while activating plugin

  • Resolved JuewelsO

    (@juewelso)


    Hello,

    We have tried a few times now to upload and activate your Events Made Easy plugin with our WordPress website. We loaded the plugin through our WP Plugins dashboard and manually by downloading the zip file and adding it via FTP. Both show this fatal error in a PHP file. Perhaps you could tell me how to fix this PHP file

    Our website: https://www.awcthehague.org

    We get this error each time we try to activate the plugin.

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected ‘[‘ in /home/thehague/public_html/site/wp-content/plugins/events-made-easy/eme_payments.php on line 1164

    Here is the line of code #1164 that it speaks about in the php file.

    ‘metadata’ => [$metadata_key => $metadata_val, ‘payment_id’=>$payment_id]

    Thanks for your help! Hope we can find a solution. We would like to use your plugin. We are running WordPress 4.8.6 .

    • This topic was modified 1 year, 10 months ago by JuewelsO.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Franky

    (@liedekef)

    Your php version is too old (older than 5.4) . I indicate that EME needs at least 5.6.
    Update to a newer version (I recommend at least 7.0) and you’re good to go (5.3 is unsupported and end of life since 2014 …)

    Hello Franky,
    Thanks for your quick response.
    As I look at our cPanel for the PHP version on our server.
    It tells me that we are using PHP Version 5.6.34
    But when I look at our system for the site it indeed says PHP Version : 5.3.29

    I’ll check further into this. Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Showing fatal error while activating plugin’ is closed to new replies.