Support » Plugin: W3 Total Cache » Showing Error message after Purging cache (Confirmed issue by 2 users)

  • Gulshan Kumar

    (@thegulshankumar)


    Fatal error: Uncaught Exception: unknown engine in /srv/users/serverpilot/apps/xxxxxx/public/wp-content/plugins/w3-total-cache/Cdnfsd_Core.php:48 Stack trace: #0 /srv/users/serverpilot/apps/xxxxxx/public/wp-content/plugins/w3-total-cache/Cdnfsd_CacheFlush.php(199): W3TC\Cdnfsd_Core->get_engine() #1 /srv/users/serverpilot/apps/xxxxxx/public/wp-includes/class-wp-hook.php(286): W3TC\Cdnfsd_CacheFlush::w3tc_flush_execute_delayed_operations(Array) #2 /srv/users/serverpilot/apps/xxxxxx/public/wp-includes/plugin.php(203): WP_Hook->apply_filters(Array, Array) #3 /srv/users/serverpilot/apps/xxxxxx/public/wp-content/plugins/w3-total-cache/CacheFlush_Locally.php(253): apply_filters('w3tc_flush_exec...', Array) #4 /srv/users/serverpilot/apps/xxxxxx/public/wp-content/plugins/w3-total-cache/CacheFlush.php(188): W3TC\CacheFlush_Locally->execute_delayed_operations() #5 /srv/users/serverpilot/apps/xxxxxx/public/wp-includes/class-wp-hook.php(284): W3TC\CacheFlush->execute_delayed_operations() #6 / in /srv/users/serverpilot/apps/xxxxxx/public/wp-content/plugins/w3-total-cache/Cdnfsd_Core.php on line 48
    
    Fatal error: Uncaught Exception: unknown engine in /srv/users/serverpilot/apps/xxxxxx/public/wp-content/plugins/w3-total-cache/Cdnfsd_Core.php:48 Stack trace: #0 /srv/users/serverpilot/apps/xxxxxx/public/wp-content/plugins/w3-total-cache/Cdnfsd_CacheFlush.php(199): W3TC\Cdnfsd_Core->get_engine() #1 /srv/users/serverpilot/apps/xxxxxx/public/wp-includes/class-wp-hook.php(286): W3TC\Cdnfsd_CacheFlush::w3tc_flush_execute_delayed_operations(Array) #2 /srv/users/serverpilot/apps/xxxxxx/public/wp-includes/plugin.php(203): WP_Hook->apply_filters(Array, Array) #3 /srv/users/serverpilot/apps/xxxxxx/public/wp-content/plugins/w3-total-cache/CacheFlush_Locally.php(253): apply_filters('w3tc_flush_exec...', Array) #4 /srv/users/serverpilot/apps/xxxxxx/public/wp-content/plugins/w3-total-cache/CacheFlush.php(188): W3TC\CacheFlush_Locally->execute_delayed_operations() #5 /srv/users/serverpilot/apps/xxxxxx/public/wp-includes/class-wp-hook.php(284): W3TC\CacheFlush->execute_delayed_operations() #6 / in /srv/users/serverpilot/apps/xxxxxx/public/wp-content/plugins/w3-total-cache/Cdnfsd_Core.php on line 48
Viewing 5 replies - 1 through 5 (of 5 total)
  • CRE8

    (@cre8gr)

    Either implement the following fix below, or revert to the previous version, until the developer fixes the problem.

    https://wordpress.org/support/topic/fatal-error-2749/#post-9779929

    Gulshan Kumar

    (@thegulshankumar)

    Thank you so much.

    Hello,

    It has been late, any idea when this issue will be fixed?

    liapnfun

    (@liapnfun)

    Hi all
    I was having the same issue for a long time
    Just fixed it by changing the following code:

    You can change the following from w3tc config file :
    so my location is like this

    /opt/bitnami/apps/wordpress/htdocs/wp-content/w3tc-config/master.php
    or you can locate this file in
    <WordPress folder>/wp-content/w3tc-config/master.php

    “cdnfsd.enabled”: “0”,
    “cdnfsd.engine”: “CloudFlare”,
    “cdnfsd.debug”: “0”,

    Make the ‘cdnfsd.enabled’ value ‘0’

    • This reply was modified 4 months ago by  liapnfun.
    Gulshan Kumar

    (@thegulshankumar)

    @liapnfun Thank you so much dear. I appreciate your help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.