Support » Plugin: W3 Total Cache » Showing Cart count as 0 in home page

  • Resolved veeraj

    (@veeraj)


    Hello,

    When I enable the W3 Total Cache plugin, it effects the cart count functionality for home page.
    It shows proper count in product pages and other also but when I go back to home page it always show 0 count.

    Please suggest how to solve this.

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @veeraj,

    If you are using WooCommerce for your website, Please follow the instructions on how to set up W3 Total Cache with Woocommerce, which you can find here
    If you have Database cache enabled, you need to make sure to add _wc_session_ to the list of Ignored Query Strings in Performance>Database Cache

    veeraj

    (@veeraj)

    Hi @vmarko,

    As per the instructions, Database cache is not enabled and neither I have enabled the Minify option.

    But still the cart count works fine in all the other pages and always shows 0 count for home page.

    Any further help will be much appreciated

    Thanks

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @veeraj,

    You need to exclude that page from being cached. Now, you haven’t provided a link to your website so I can not check it but evidently, that page needs to be excluded from caching.
    You can do that by going to your WP Dashboard, Performance>Page cache, scroll down to advanced and add that page to Never cache the following pages: field.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Showing Cart count as 0 in home page’ is closed to new replies.