Support » Plugin: F2 Tumblr Widget » Showing ’ instead of ' and  after :

  • Resolved starletbeam

    (@starletbeam)


    I’ve tried changing my theme header to try and solve the problem, but it seems like somewhere in the f2-tumblr.php code for retrieving body data I’m getting an error.

    $tumblr_data = wp_remote_retrieve_body(
    wp_remote_get( $tumblr_url )

    My site is getting strange charactersets even though it’s displaying URF-8. I’m not sure if that’s actually where the error is, but I’d appreciate the help.

    https://wordpress.org/plugins/f2-tumblr-widget/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author fsquared

    (@fsquared)

    Sounds like the tumblr you’re importing from has some (probably copy/pasted) “smart” quotes, which are not reliably rendered everywhere. You would have expected that setting your site to UTF-8 would resolve this, but it’s not always the case 🙁

    I’ll add some code to try and do the right thing with these characters; however as it’s monkeying around with content I’ll probably make it optional (although defaulted to ‘on’) so that if people want to preserve their more esoteric characters, they can!

    A new version should get pushed out in the next day or two.

    Plugin Author fsquared

    (@fsquared)

    I’ve just pushed the latest verion (0.2.4) which adds code to handle smart quotes in tumblr posts; this should clear the problem up.

    As I mentioned earlier, it’s optional so if there are any issues you can always until the “replace special characters” checkbox to revert to the way it used to work.

    I’ll mark this as resolved for now.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Showing ’ instead of ' and  after :’ is closed to new replies.