WordPress.org

Support

Support » Plugins and Hacks » Q and A Focus Plus FAQ » Show/Hide Behavior Doesn't Work

Show/Hide Behavior Doesn't Work

  • Hi,

    The Show/Hide behavior doesn’t work for me. The Question is listed, but I can only click on it to get to another page with the full answer. It does not expand to show me the answer on the same page.

    Could you tell me what I am doing wrong?

    I am using the Atahualpa theme version 3.7.13, and WordPress 3.8.1.

    Thank you for the wonderful plugin.

    Regards,
    Kennis

    https://wordpress.org/plugins/q-and-a-focus-plus-faq/

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author ELsMystERy

    @elsmystery

    Is show/hide enabled in the settings?

    Yes, it is.

    Plugin Author ELsMystERy

    @elsmystery

    Is Javascript enabled in your browser? If so, when you do a view source of the page so you see any jQuery.js files? Can you post the URL so I can look at the page?

    My Javascript is enabled. This is the page: http://everything-orchids.com/orchid-growing-faqs

    Plugin Author ELsMystERy

    @elsmystery

    It is working fine for me on IE and Google Chrome. It is probably a browser setting, you should double check the JavaScript setting. If you can try a different browser, do that.

    hmm, I just used my other laptop and iPad, and it also worked on those. Apparently it’s only my mac that doesn’t work, but I don’t know why.

    I suppose it’s OK if it’s only me. Thanks for looking into it.

    Plugin Author ELsMystERy

    @elsmystery

    I am pretty sure is is most likely a setting somewhere, I just don’t know where (don’t have a Mac).

    It said in your FAQ that questions about resolved issues will not be replied to, so I’m posting my question here, in the same topic.

    Overall, I love the plugin – works like a charm except for the detail of expanding the questions (which, unfortunately, is pivotal to good UX/UI practices).

    I am experiencing the same symptoms as kenniswong1977 described. I have tried Safari, Firefox, and Chrome. The symptoms are the same in all browsers. Javascript is active and when I view the page code I can find the jQuery.js file. No issue there. Show/hide is enabled in the settings.

    I am using the Vantage theme by SiteOrigin and WordPress 3.8.1.

    I am using a Mac, but my partner has Linux on his PC (we do not have any computers with Windows in our household). The question is not expanding for either of us. My page is currently set as a draft, but I can publish it temporarily.

    Are there any known conflicts with other plugins?Perhaps I have missed some small, but vital detail?

    Thank you for taking the time to assist with this issue.

    Best regards,

    Sara

    Plugin Author ELsMystERy

    @elsmystery

    I am not aware of any compatibility issues with other plugins. The most I can do is see if I can find a problem with the JavaScript that is causing this behavior on some Macs (not all). My best guess is that the current version of JQuery that WP uses has a bug that conflicts with something on whatever versions of Mac this problem appears on. If I can find a fix, I will release an update with it, otherwise it ma be a JQuery issue, which I have no control over, aside from dumping JQuery and including custom JavaScript instead.

    With that said, I am in the middle of another very large project right now, so it may be a while.

    In the meantime, if there is a time when it did work correctly, and you can give me an idea of when it stopped, I can see if something that was changed in an update needs to be adjusted.

    Plugin Author ELsMystERy

    @elsmystery

    I did think of one thing you can try. Turn the show expand/collapse feature off, or on and see if this makes a difference and let me know. Thanks.

    Thank you for your swift reply, ELsMystERy.

    The issue has persisted for the entire time I have used the plugin. I have tried turning the expand/collapse feature off and on to no avail, I’m afraid. As I said previously, the plugin otherwise works beautifully.

    To make the FAQ page a little more user friendly, I worked around the issue by copying the questions and answers into a separate page and used a shortcode to create the the expand/collapse effect. I installed the shortcodes after the FAQ plugin and it does not seem to be causing any conflicts.

    I have activated the FAQ page function temporarily. I will leave it active for a few hours, so you have a chance to look at the page. I hope you don’t find it too confusing (the plugin-generated page is at the top and my manual entries are below it).

    http://scenarioexpertis.se/about/faq/

    I look forward to reading your response. Thank you for finding time to help out. It is much appreciated.

    Best regards,
    Sara

    Plugin Author ELsMystERy

    @elsmystery

    The top part is not functioning for me either. Have you tried it with a different theme to see if something about the one you are using might be causing the problem? I have not encountered this issue with the themes I have been using.

    Also, You have some syntax errors on the page that may be the problem:

    Uncaught Error: Syntax error, unrecognized expression: . jquery.js?ver=1.10.2:3
    at.error jquery.js?ver=1.10.2:3
    mt jquery.js?ver=1.10.2:3
    kt jquery.js?ver=1.10.2:3
    at jquery.js?ver=1.10.2:3
    x.fn.extend.find jquery.js?ver=1.10.2:4
    x.fn.x.init jquery.js?ver=1.10.2:3
    e.fn.init jquery-migrate.min.js?ver=1.2.1:2
    x jquery.js?ver=1.10.2:3
    (anonymous function) (index):843
    c jquery.js?ver=1.10.2:3
    p.fireWith jquery.js?ver=1.10.2:3
    x.extend.ready jquery.js?ver=1.10.2:3
    q jquery.js?ver=1.10.2:3

    Resource interpreted as Script but transferred with MIME type text/html: “http://www.formilla.com/ajaxhandler.aspx?rnd=0.6989956949837506&f=loadFormi…0be&ChatSessionGuid=undefined&UserEmail=&callback=renderFormillaChatButton”. feedback.js:68
    Formilla.dynamicJSONTag feedback.js:68
    Formilla.loadFormillaChatButton feedback.js:60
    script.onload.script.onreadystatechange (index):828

    Looks like the Syntax errors are due to my Live Chat plugin. I’ll have a word with them.

    Thank you for your help!

    Plugin Author ELsMystERy

    @elsmystery

    Have you tried disabling the live chat plugin to see if that solved the problem with the FAQ?

    Not working here either – site validates fully with W3, so I’m not sure what’s causing it. I can provide site access if anyone can take a look.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Show/Hide Behavior Doesn't Work’ is closed to new replies.
Skip to toolbar