• Resolved Roger Trewenack

    (@rogertrewenack)


    we were using the show command to display the category & subcategory hierarchy for members to choose from.
    Unfortunately we had that page corrupted & lost the code.
    What were initially displaying was the “Categories” – selecting one of those categories would advance you to a display of the relevant “sub-categories”. Selecting any of the sub-categories would present you with a display of products.
    This was all achieved with ONE LINE of code – [show_categories ???????]
    If we use [show_categories] we get a display of all the categories & subcategories at once…
    Hope this makes enough sense & that you can help??? Please.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author ndre

    (@ndre)

    Hi @rogertrewenack,

    Please try:

    [show_product_catalog]

    Thread Starter Roger Trewenack

    (@rogertrewenack)

    Hi @ndre,
    Thanks for your feedback, but, unfortunately that doesn’t work at all. it returns this
    ———————————————————————–

    Currently, no page is set to show the main product listing. Would you like to show product listing here?
    
    All your individual product pages will include this page slug as a parent.
    
    Yes
    * Use the show_products or show_categories shortcode if you just want to display products or categories.

    ———————————————————————–
    What I wanted was not product hierarchy, but category hierarchy, so I tried using
    [show_categories_catalog]
    No error, no display – it doesn’t produce anything but the command itself!
    I’ve tried a few other variations, but with no success…….

    Plugin Author ndre

    (@ndre)

    The provided shortcode is the correct one to display the category hierarchy like this. For best results, you should use this shortcode on the main catalog page (this is why the info shows up).

    As an addition you should go to the catalog settings and switch the two options:

    Main listing shows: Main Categories & Uncategorized Products
    Category Page shows: Subcategories

    Thread Starter Roger Trewenack

    (@rogertrewenack)

    hi @ndre,

    thanks for confirming that – we have since discovered that we have a corrupt catalogue, which refuses to show us anything.
    so, now we’re in the process of restoring back to a time when it worked!!
    This will in turn restore the page we damaged, causing this issue we raised on the forum.

    so I guess that means we can close this forum record?

    Thread Starter Roger Trewenack

    (@rogertrewenack)

    Hi support, we’re back from our disaster, which we think turned out to be deleting a “manufacturer” which still had active “products” in the catalog.
    Once we removed the offending products, the catalog stopped failing with a critical error.
    However, after a few days of adding more products to the catalog, and also a few new manufacturers, we now find that to display of “product” doesn’t complete.
    more explanation: using the “show_product_catalog” command, we get to see the top level “category”. selecting a category then shows the correct group of “sub-categories”. Then we select the “sub-category” and we see the ‘product’.
    When we then select the ‘product’, we get thrown back to the initial catalog display.
    Note that on our SCALE MODELLING website we have changed the names:
    ‘Category’ becomes “Genre”;
    ‘Sub-category’ becomes “Sub-Genre”;
    ‘Product’ becomes “Model”;
    ‘Manufacturer’ becomes “Modeller”.
    We have another query, which might be solvable as part of this one?
    How do we get to display ‘Manufacturers’ (“Modellers”) names, then the list of ‘Products’ (“Models”) that they have made?

    Plugin Author ndre

    (@ndre)

    Hello @rogertrewenack,

    Are you using the Product Manufacturers extension? If you are using any premium extensions please submit a support ticket as we cannot support premium plugins here.

    If you are not using any premium extension, please let us know how you assign the manufacturers.

    Thread Starter Roger Trewenack

    (@rogertrewenack)

    Hello @ndre,

    Yep, we’re using the Product Manufacturers extension – I’ll submit a support ticket.
    Thanks

    Roger

    Thread Starter Roger Trewenack

    (@rogertrewenack)

    Hi ndre – I’m not getting any response from support, despite logging 2 support requests & 2 chat attempts.
    I now have “Critical Error” on all attempts to display any part of the catalog.
    I can search by date ‘2021/07’, but then trying to look at anything brings up critical error.

    Sorry to bug you, but you seem to be the only one responding……

    Roger Trewenack

    Plugin Author ndre

    (@ndre)

    Hi @rogertrewenack,

    Please check your spam folder as we sent the response to both tickets.

    Thread Starter Roger Trewenack

    (@rogertrewenack)

    Hi @ndre,

    nothing in junk folder!

    I’ll have to go online to find those responses, I guess..

    Thread Starter Roger Trewenack

    (@rogertrewenack)

    Hi @ndre,

    How do I find those responses??

    Plugin Author ndre

    (@ndre)

    Hi @rogertrewenack,

    I re-sent both responses to the Gmail and private accounts.

    Thread Starter Roger Trewenack

    (@rogertrewenack)

    Hi @ndre,

    OK – working on setting up a temp admin account.

    Thread Starter Roger Trewenack

    (@rogertrewenack)

    Hi @ndre,

    Could you please supply me with more information as to how you fixed this problem yesterday, including anything we should be aware of going forward.

    We want to ensure that we learn what we can from this latest problem, to help avoid making the same mistake (if applicable) in the future.

    Roger Trewenack

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.