WordPress.org

Forums

Yet Another Related Posts Plugin (YARPP)
[resolved] Show the YARPP sidebar widgets ONLY on posts (4 posts)

  1. yaniv691
    Member
    Posted 1 year ago #

    How do I show the YYARPP sidebar widget only on posts?

    It's currently showing on my front page (blogroll), and it says, of course - no related posts.

    Is there a fix to this that's no just a display:none in CSS?

    Thanks!

    https://wordpress.org/plugins/yet-another-related-posts-plugin/

  2. jeffparker
    Member
    Plugin Author

    Posted 1 year ago #

    What theme are you using? Some themes use the homepage as a collection of archives. See if the "Also display in archives" checkbox is checked. (It's in the "Display options" section of the WP YARPP Settings.)

    And yes, a "display:none" will hide it from the home page, but you'll need to make sure you correctly target the appropriate home IDs and classes.

  3. yaniv691
    Member
    Posted 1 year ago #

    I'm using the LesPaul! theme. "Also display in archives" is not checked.

    I thought there's a way to disable the widget on the homepage from the back-end, but I ended up hiding it with CSS.

    Thanks!

  4. jeffparker
    Member
    Plugin Author

    Posted 1 year ago #

    There are a lot of settings, including custom widgets, in that theme so I wouldn't be surprised if there's a setting that would fix the issue. However, I don't want to purchase that theme in order to test, so hope your CSS solution works for you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yet Another Related Posts Plugin (YARPP)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.