Show the most recent: n days problem (4 posts)

  1. woolgatherer
    Posted 10 years ago #

    I've just moved my blog to a new ISP server and all seems to have gone well other than my Reading option seems to have broken.
    I have "Show the most recent: 1 days" set but am seeing 2 days' worth of posts.
    If I change the number of days, say to 3, I get days set + 1 (i.e. 4). If I change it to show 1 single post it works fine. But I want 1 day! It is a multi-user blog and will become quite busy and I really want to keep on displaying just today's posts on the main page.
    Can anybody help? I am running 1.2 Mingus and it worked perfectly up until now.

  2. Anonymous
    Posted 10 years ago #

    What happens if you set it to zero days?

  3. woolgatherer
    Posted 10 years ago #

    Ah. I set it to 0 days and got 0+1=1.
    Until I made another post and then got no posts at all.
    Interestingly th eproblem seems to have fixed itself with the later posting and am now working on the principle that the previous last posting caused some kind of blip.
    I am worried though that I have a database error or a plug in conflict as there was some kind of interplay between the page post listings and another plugin - the Page Navigation 1.2 GaMerZ plugin.
    Oddly, when I set days to more than 1 (when the listings were broken) the Page Navigation links vanished. They worked OK when I set it to 1 days (but was getting 2 days posts)
    I think the technical term for what we have here is a "b*ll*king mess"
    I dislike unexplained problems that go away on their own ....

  4. brianbonner
    Posted 9 years ago #

    That is strange, I set it to one day in the dashboard and it displayed ALL my posts.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.