Show the most recent 'n' days bug? (4 posts)

  1. optimystic
    Posted 12 years ago #

    Hi. I do not know if this is the right forum to raise this issue, but I thought since it involved giving feedback, it could go in here. I've very recently installed WordPress and am currently in the process of setting it up before launching it. I imported my blogger posts into WordPress (and it went off smoothly!)
    When I configure the Reading Options to display, say, 7 days worth of posts (Show the most recent), it shows me those many posts correctly. But if I try to delete a post after that, then subsequent loads of 'index.php' result in all of my previous posts getting loaded on the main page... and not just 7 days worth of posts. Nothing seems to stop all the posts from getting loaded on the main page, except the following:
    1. I go to the Reading Options and change the setting to display 'n' number of posts (rather than days).
    2. I publish a new post while keeping the setting in the Reading Options to display 'n' days.
    I do not know what could be causing this anomaly, though logically it seems to be a WP bug. On the other hand it could be entirely my fault. Any help would be greatly appreciated.

  2. twistedsymphony
    Posted 11 years ago #

    I'm having the same exact problem with my blog: http://www.web-nine.com/blog/
    I just ran a search looking for a solution but alas... I only find another with the same problem.
    I also imported from blogger... I wonder if that is part of the problem?

  3. brianbonner
    Posted 10 years ago #

    I have the same problem, although I haven't tried publishing a post with n days set. I just tried one and it appeared rto be loading all my posts.

  4. vkaryl
    Posted 10 years ago #

    Y'know, brianbonner, you'd be better advised to start a new topic than resurrecting two that are over a year old.

    [Edit: I see that you did.]

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.