WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Show slider full width

[Resolved] Show slider full width

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    Hi @nomafo, try setting the slideshow to 1800px width, then enabling the “Make this slideshow responsive” option. Does that work?

    No, that does not work

    this is the site http://bonbon.nomafo.be/

    Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    Hey again. The slideshow is resizing for me? I don’t see any issues 🙂

    Can you explain in more detail?

    The width of the website is 1000px

    but the slider should be 1800px wide.. but it stays in the same size of the website.

    It should be 1800px over the width of the entire page

    Hope I explain it well

    Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    Hi @nomafo, that’s because the slideshow is contained within the boundaries of your theme. This is how responsive slideshows will work – they will fit themselves to the container they are within, which is 1000px in this case.

    If you want to fix the width to 1800px and go beyond the bounds of the theme, you’ll need to disable the responsive functionality, but of course this will keep the slideshow at 1800px width even on mobile devices.

    Not sure if what you’re looking to achieve is possible 🙁 Sorry about that – if I’m understanding correctly, it goes against the principals of a responsive design & slideshow. Very sorry about that.

    Hi,

    I know it is possible with an image, to show it 1800px wide

    It was done with this code in the css file
    img[src*=”frontpagekleiner”] {
    width: 120%;
    margin-left: -200px;
    }

    Can the same be done with the slider?

    Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    Unfortunately not as a slideshow is a little more complicated than an image 🙁 It isn’t possible to set the slideshow to 120% width – it relies on finite values and mathematics to create it’s dimensions responsively. Sorry about that.

    Or can i set the width to pixels instead?

    Or any other solution?

    Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    Yes, if you set the pixels and disable the responsive functionality you can do this using negative margins 🙂

    And what do i add to the Css file then?

    Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    Try:

    .easingsliderlite {
        margin-left: -400px !important;
    }

    doesnt work,
    i see a scrollbar underneath the slider now
    http://bonbon.nomafo.be/

    i have it set to non responsive

    Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    Ok. Try this CSS instead:

    .art-layout-cell.layout-item-1 pre {
        margin-left: -300px !important;
    }

    Yes, that works partially

    http://bonbon.nomafo.be/

    it should show over the entire width, but the scrollbar is still appearing

    Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    Ok, try this:

    .art-layout-cell.layout-item-1 pre {
    margin-left: -300px !important;
    overflow: visible !important;
    }

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] Show slider full width’ is closed to new replies.