Support » Plugin: WooCommerce » Show Flat Rate, Hide other shipping methods

  • Resolved twinstar1


    I am using the Flat Rate Shipping component of Woo Commerce, alongside the Ozpost Plugin. Both serve my requirements almost perfectly.

    I am using my Transdirect account within Ozpost plugin and it is working better than expected. (Unlike the actual Transdirect Plugin which is completely useless).

    The only issue I am facing is that I have set up Flat Rate Shipping in Woo Commerce. While the Ozpost plugin shows the Flat Rate cost which is awesome, it also displays the Transdirect shipping costs (Ozpost), even when a Flat Rate applies.

    In short, what I need to do is hide the Transdirect quotes from Ozpost, when Flat Rate Shipping is used as a Shipping Method. If Flat Rate does not apply, then I would like the Ozpost plugin to kick in with the Transdirect quote.

    The Ozpost plugin does not appear to have a function which allows me to hide its quotes when Flat Rate Shipping is present, though interestingly it is overrode by Free Shipping.

    Is there a way to make Woocommerce ignore the Ozpost plug in, when Flat Rate is a Shipping Method?

    Any help would be appreciated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support stephjacq


    Automattic Happiness Engineer

    You can use the Advanced Shipping Packages plugin to set which shipping methods apply for particular products:

    This can exclude Ozpost as an option when Flat Rate is applicable.

    Thanks Stephjacq, I will check out this plugin. I don’t suppose there is a way to try this plugin before I buy it is there?

    Plugin Support Three Sons


    Hey @twinstar1,

    Sorry for the delay in getting back with you about this. There isn’t a way to try out the plugin before purchasing, but it does have a 30-day refund window. You can purchase it and try it out. If it doesn’t meet your needs, you can get your money back.

    If you have any questions, please let us know.


    Plugin Support EtienneP


    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.