Support » Plugin: Seriously Simple Podcasting » Show Episodes Full Description in RSS Feed

  • Resolved cambell

    (@cambell)


    Hey Guys,

    first things first: I really love Seriously Simple Podcasting, it’s a fantastic tool for self hosted podcasts!

    Recently, our podcast has been added to Spotify. Everything works perfectly fine except for our episode descriptions. While iTunes shows the full description, in Spotify it gets chopped of in the middle with only “[…]” at the end.

    I’ve checked the RSS feed to see, if this is a Spotify only issue but the description in our feed is also chopped of in the middle. Spotify is definitely able to show lenghtier descriptions so the problem definitely lies somewhere else. I’ve also enabled the “show full text in feed”-option in WordPress itself and forced the feed to update itself with no result.

    My questions are: Why is iTunes able to pull a full summary while the feed only shows an excerpt and other services can’t? Is there a way to update the RSS Feed, so it includes the full text of the episode?

    As mentioned above: Our episode descriptions are a unique selling point to our podcast so that we really need them to show up in full on Spotify. It’d be awesome if you could help me fix this problem.

    Best wishes and merry christmas!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Craig Hewitt

    (@podcastmotor)

    Hi @campbell

    Thanks so much for the message and hope you had a nice holidays as well.

    Could you send us an example of where/how the description is getting cut off in the Spotify page so we can look at this more thoroughly? Have some initial thoughts but want to make sure we’re barking up the right tree first.

    If you could just send us the episode title you’re looking at and what you see in Spotify that’d be great.

    Hi Craig, thanks for your reply!

    Here is a link to screenshots on both sites, feed and Spotify: https://imgur.com/a/KpXXk74

    On Spotify, you can only open one episode at a time, which is why you cannot see the others cut off like the first one but it’s the same there.

    They get cut off with “[…]”. I found out that this is precisely after 55 Words. As mentioned before I already switched off excerpts for my RSS Feed but nothing has changed since then.

    Thanks for your help!

    Hey Guys,

    it’d be really nice if there is any way to fix this problem.

    Thank you so much!

    Plugin Author Craig Hewitt

    (@podcastmotor)

    Hi @campbell,

    Thanks for the bump on this. We’re prioritizing this into our next dev cycle now, and hope to get this out to everyone shortly here after the holidays.

    Will keep you posted

    Hey Craig, any news?

    Plugin Support Eileen Violini

    (@iviolini)

    Hello @campbell we recently released a new version. Can you check to see it the update fixed your issue?

    Thanks!

    Hi iviolini,

    unfortunately, the descriptions are still getting cut off on Spotify after 55 words.

    We’ve just released another new episode and the problem still exists.

    I am really hoping you guys can fix this!

    Best wishes
    cambell

    cambell

    (@cambell)

    anything?

    Plugin Support Eileen Violini

    (@iviolini)

    Hello @campbell our team is still looking into your issue and will have an answer for you soon.

    I’m in the same situation. I leave screenshots of configuration and the output: https://imgur.com/a/U3qgDkA

    The content is much longer, and the feed URL is this: https://negocioswp.es/feed/podcast/

    Even I have “Full Content” in Settings > Reading > RSS content.

    Yeah, unfortunately it still hasn’t been fixed..

    Plugin Author Craig Hewitt

    (@podcastmotor)

    Hi there. The reason that you’re seeing this issue is very likely due to the stylesheet that SSP applies to your feed page by default. This is designed to make your RSS feed more readable by humans, but in some cases (like the one that you’re running into) it can hamper other 3rd party applications from displaying the entire feed contents.

    In this case, you can apply this bit of code to your theme’s functions.php file to remove the stylesheet from your feed: https://gist.github.com/TheCraigHewitt/ebaebfdad8c3dfc44c9ce625bc09b089

    Note, this will make your feed page look exactly like if you were to right click on your feed page now and select “View Page Source”. This will show just the raw XML of your feed.

    Hope that helps, and if there’s anything else we can do just let us know.

    I don’t see any change adding that code.

    Note, this will make your feed page look exactly like if you were to right click on your feed page now and select “View Page Source”. This will show just the raw XML of your feed.

    Anyway, checking the Page Source I see that the content is not complete 🤷‍♂️

    • This reply was modified 2 months, 1 week ago by Elias Gómez.
    Plugin Author Jonathan Bossenger

    (@psykro)

    Hi @campbell @eliasgdj

    Thank you for your feedback.

    I have created an issue in our GitHub issue tracker here

    https://github.com/TheCraigHewitt/Seriously-Simple-Podcasting/issues/411

    Could I ask you to add your specific RSS Feeds and set up details to that ticket, that way I can replicate the problem and work towards issuing a fix.

    Thanks

    Done!

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.