Support » Plugin: Advanced Excerpt » Show Entire Post Rather than Excerpt

  • Resolved erod1874

    (@erod1874)


    How would I get the Posts page to show the entire post rather than just an excerpt? For the life of me I cannot get the entire post to be shown. I have tried to modify the php files in the child theme directory, tried changing settings in the dashboard and still nothing. I have tried setting “Excerpt Length” to 99999 words in the plug in settings but it still cuts off at around 144 words.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author WPKube

    (@wpkube)

    Hi,

    The theme Zigcy handles the excerpt and the word limit in it’s own way (as far as I know that’s not allowed in themes on the official WordPress.org theme directory) so the filters our plugin uses do not apply.

    But, what you need is actually the opposite of what the plugin is meant for.

    To make the theme display full content you need to make a small modification to the theme.

    The file in the theme is template-parts/content-archive.php On line 47 is:

    echo zigcy_lite_get_excerpt_content();

    That should be replaced with:

    the_content();

    It will then display the full content.

    I’d suggest doing this using a child theme so the change does not get overwritten on theme update. Also, perhaps you can contact the theme author and ask for an option to switch the main blog page to show full content.

    It worked like a charm. Thank you

    • This reply was modified 4 months, 1 week ago by erod1874.
    Plugin Author WPKube

    (@wpkube)

    You’re welcome.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.