WordPress.org

Forums

Show Embedded Videos on Category Pages (5 posts)

  1. Mike
    Member
    Posted 2 years ago #

    Could someone be kind enough to tell me how to accomplish this?

    here is the specific site in question - http://bit.ly/McW1Gu [FYI - website for a sex & intimacy coach, nothing graphic, just fyi]

    as you can see, the 'podcasts' page is meant to be a blog feed of youtube videos, and it is set up so that the author can simply assign such posts to the 'podcast' category.

    i've spent hours looking through other wordpress.org troubleshooting posts and tutorials around the interwebs, and so far nothing but dead ends -- a lot who claim to have the solution, but no solution that has actually worked for me. About given up on my own.

    It's a shame that this is so difficult and involves hacking at all. (note to Matt Mullenweg: how do you expect WP to ever compete w/ Tumblr this way?)

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    This has nothing to do with WordPress core and everything to do with your theme's category template file.
    See category templates

  3. Mike
    Member
    Posted 2 years ago #

    Should this post be moved to the "Themes and Templates" section?

    yes, I do recall that one suggested solution had to do with whether the category page template is set to show full post or excerpt, but I did not have any luck with it

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Should this post be moved to the "Themes and Templates" section?

    Moved.

    I did not have any luck with it

    So what does your category template file use the generate the post teaser?

  5. Mike
    Member
    Posted 2 years ago #

    i think i've stumbled onto the solution. i realized there was nothing in the archive.php which i thought was normally the template used for category pages. i went searching through all the themes files using control+f to find any of these terms

    the_excerpt
    the_content
    category

    and none of these three surfaced anywhere, so i just looked through the code, and in the content.php file i noticed,

    theme_get_excerpt()

    so i just took a shot in the dark and changed it to

    theme_get_content()

    and it seems to have worked

Topic Closed

This topic has been closed to new replies.

About this Topic