Support » Fixing WordPress » Should I upgrade to PHP5?

  • Resolved brianbonner

    (@brianbonner)


    My host has the option for me to upgrade to php5. I am currently having cpu overages and was wondering if this would help, or if WP 2.0.4 even supports php5?

Viewing 3 replies - 1 through 3 (of 3 total)
  • WordPress minimum spec is PHP 4.2 or later. That said, there was a minor issue with WordPress 2.0.3 with escaped characters that didn’t ocurr with PHP 4.3. There was a workaround, and I’m not sure if the issue was resolved with 2.04 or not, because I bit the bullet and upgraded to the latest in the 4.x series. However I see no reason why WPress shouldn’t work with 5.x it is forward compatible in that 4.x code should run with 5.x, although the reverse may not be true. However I am a PHP noob myself, so if others know different, please advise!

    And I don’t know if this is a help or not, but my xampp local server runs php 5.1.4.4 – and wp 2.0.4 works perfectly with it.

    It does help vkaryl, I have requested to be upgraded to php 5, now I will see if the server running phpf and mysql 5 is more efficient.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Should I upgrade to PHP5?’ is closed to new replies.