WordPress.org

Forums

Jetpack by WordPress.com
[resolved] Shortlink not working and pointing to direct URL (9 posts)

  1. cyang1020
    Member
    Posted 1 year ago #

    I transferred my blog from WordPress.com to a self-hosted site about 5 days ago. One of the issues I'm experiencing is that the shortlink for each post is not working properly. At first it was pointing to the direct URL but it was at least taking me to the right page of the post. Now that I've changed the format of my permalinks, the shortlinks generated by each post are taking me to an error page.

    https://wordpress.org/plugins/jetpack/

  2. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

  3. cyang1020
    Member
    Posted 1 year ago #

    This particular issue has been resolved since I posted it. I do have another issue that I posted that I didn't get a reply to. It looks like I'm using the Jetpack comment form for my posts but I cannot figure out how to change the prompt from "Leave a reply" to something else.

  4. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi,

    In your site's dashboard, visit the Settings->Discussion page. Near the bottom is the option to change the text from "Leave a reply" to anything of your choosing.

    Cheers!

  5. cyang1020
    Member
    Posted 1 year ago #

    I had that option when I was using WordPress.com but now after transferring over to a self-hosted site and using the Jetpack comment form, that option is no longer available under Settings>Discussion.

  6. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    It should still be there if you have the Comments module active. On my site, it is the very last setting at the very bottom of the Settings->Discussion page.

    What's your URL?

  7. cyang1020
    Member
    Posted 1 year ago #

    My URL is myrosecoloredshades.com.
    I guess I'm not using Jetpack comments then. But I still can't figure out where I can change the Comments prompt. I looked in the Editor and looked at suggestions from other forum posts and no success.

  8. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Correct—Jetpack Comments aren't enabled on your site.

    You can add this to your theme's function.php file to change it. The Forever theme is using the WordPress default language, so it isn't declared directly by the theme.

    https://gist.github.com/kraftbj/5e55da0a04435765591d

    You can change "Tell me something good!" to whatever you like. The second line (title_reply_to) is used for replies, but at first glance might not be used on your theme.

    Cheers!

  9. cyang1020
    Member
    Posted 1 year ago #

    It worked! Thanks so much for your help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags