Support » Plugins » Shorten2Ping Plugin

  • Thank you to samuelaguilera for a great plug-in. This has the potential of easily updating social networks.

    One thing that I cannot figure out how is that the updates that it is creating omit the URL from Facebook.

    Here is the “code” that I have entered into the Status Message entry on Shorten2Ping page on my site:

    New post, [title] – [link]

    Can you tell me what possibly I need to fix?

    Thank you as always.


Viewing 15 replies - 1 through 15 (of 30 total)
  • Check your configuration or link shortener configuration (the one you are using, not de S2P configuration for it).

    I’m sure that is not a S2P problem.

    I will post again after I check these things and will let you know. Thanks Samuel,

    Dear Dobner and others, I found out what the problem was. By going to and carefully reading what the instructions were, I realized that Ping shortens the URL automatically all by themselves. That’s right, you don’t need to sign up for or any of the others if you are going through

    So, if you are using Shorten2Ping and you are not getting your URL’s to show up, go back and take off the setting to shorten the permalinks with any other service, set that to “Nothing” and then give it a try. I think you will find that will shorten them all by itself.

    Putting one other shortening service in there (like just sort of countermands the way that Ping operates and so the link doesn’t show up at all.

    This worked for me, I hope it works for you. Shorten2Ping is a great plug in. ¡Muchas gracias, Sr. Aguilera!

    Thanks for posting your results Fabienne.

    Gracias a ti! 😉


    That is optional. Ping.FM short the URL and should be used if you wish to benefit of their click statistics.

    Until Samuel decide if he adds or not my modifications to Shorten2Ping I made available Shorten2PingNG in our WordPress plugins folder at Box.Net.

    This version is mostly Samuel’s one with the add of per user options and a few small other modifications. This is really useful when you have multi-author blogs and each author has his/her own social network places to (re)post to.

    ipublicis: I’m willing to include your mods and to add some user requests, but the problem is that I don’t have too much spare time for this until now 🙁

    I hope to have it not too late…

    I installed this plugin few minutes ago but I cannot activate since it doesn’t appear
    on my plugin panel. What should I do?

    Not a plugin problem. I’m sure there was some problem writing the files on your hosting…

    Check your wp-content/plugins/ dir, locate the shorten2ping dir and delete it. Install again.

    If you want to install fail safe, download the plugin to your computer first, and then upload manually to wp-content/plugins

    I actually did what you wrote and I got the message “The plugin does not have a valid header.” What does this mean?

    The only reason for that message error is a corrupted/modified file.

    I download the file to my Mac and compress it to a zip file. Is there something wrong
    that I’m doing in this process?

    I’ve come aross a rather annoying problem that just started about three days ago. Some, not all (seems very random in fact), of my posts are being double pinged to I just has a scheduled post hit the internet and indeed added two entries to be pushed out ( and both go to the same post) within on minute of eachother.

    As I noted it just started about three days ago and not on every post. Thoughts?

    Well, darn. Now I am having trouble again. My posts are not showing in Facebook any more. I was also told that they didn’t have good links now in Twitter. This just started happening on 2/27. Any ideas? I have tried to use it with chosen and “both” chosen.

    Did you check the custom fields of the posts affected?

    If your WP tries to do the “ping” and any of the services gives an error message, it’ll be stored in the custom fields of the post.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Shorten2Ping Plugin’ is closed to new replies.