WordPress.org

Support

Support » How-To and Troubleshooting » shorten URL using .htaccess not working

shorten URL using .htaccess not working

  • I have WordPress installed in a shared hosing account. WordPress is installed in mydomain.com/public/wordpress.
    I use .htaccess file at mydomain.com to redirect to the WordPress folder which works fine.
    Then I want to take the word “WordPress” out of my path, which I have been trying VERY UNSUCCESSFULLY to do using .htaccess.
    It doesn’t “seem” like it should be this difficult, but… Can someone tell me what I have done incorrectly? I have the following .htaccess file in the WordPress folder:

    Options +FollowSymlinks

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^/(.*)$ /$1 [QSA,L]
    </IfModule>

    # END WordPress

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘shorten URL using .htaccess not working’ is closed to new replies.