Support » Plugin: Shortcodes Pro » Shortcodes with Select attribute no longer working with 3.9?

  • I know this is a long shot since the plugin author seems to have gone AWOL for a while, but…

    I recently upgraded WordPress to 3.9, and now my shortcodes that use a Select attribute (i.e. a pulldown list) no longer work. I still get the pop-up with the pulldown menu, but when I click on Insert, I get this:

    Shortcode not found. Please verify your settings

    Does anyone know of a way to fix this? Shortcodes Pro is an incredibly useful plugin, and I can’t find anything that can replace it. 🙁

    https://wordpress.org/plugins/shortcodes-pro/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Hi,
    I have the same error when I try to use Shortcodes Pro on wordpress 3.9

    If someone could help us …..

    Having the same problem here since upgrade to 3.9 please let us know.

    Hi!

    We solve this problem in our WP 3.9 and made a repair guide.
    if you are interested send me an e-mail support@movie-check.at

    Thank you cdoo, your solution worked like a charm!!

    Anyone else who has this problem, I highly recommend that you drop cdoo a note. It’s a simple fix.

    Hopefully the plugin author will fix it one day!

    Thank you cdoo your solution worked like a charm!

    Any way you could post the solution to this thread?

    not really, i send you a 1:1 replace file.

    It’s a very simple fix. Version 3.9 of WordPress incorporates a new version of TinyMCE. This new version (TinyMCE 4) no longer includes one of the functions required by Shortcodes Pro.

    You simply need to edit the following file:
    shortcodes-pro/inc/shortcodespro-overlay.php

    And replace the following line:
    window.tinyMCE.execInstanceCommand('content', 'mceInsertContent', false, shortcodeContent);

    With this:
    window.tinyMCE.execCommand('mceInsertContent', false, shortcodeContent);

    I couldn’t understand why cdoo didn’t just post the solution to this thread. But then I found out he was asking for donations for this very simple fix.

    Thank you very much dazboy for your help.
    Like you I really don’t understand cdoo …….

    We worked for several hours to solve this problem (try & error).
    The idea about the “donate button” was like “a beer for solving the problem”.

    However: If anyone have integration issues – just contact us/me.

    btw: before you edit a php file in your wordpress installation – backup the original one!

    I think the author didn’t developed this Plugin in a couple of hours, but he contributed it 4 free … So, in my opinion, even a bugfix should be free to cherish all the work and make the Plugin work in the current Version for everyone!

    Thank you dazbot!

    Thank you so much @dazbot! That worked like a charm!

    Unfortunately I tried dazbot’s solution but it’s still broken. Any other ideas to solve this?

    Shortcodes Pro is such a nice plugin, it’s sad that I cannot use it anymore.

    Thanks dazbot.

    Worked also for me. Thanks dazbot!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Shortcodes with Select attribute no longer working with 3.9?’ is closed to new replies.