Support » Plugin: WordPress Shortcodes Plugin — Shortcodes Ultimate » Shortcodes stripped in Excerpt

Viewing 4 replies - 1 through 4 (of 4 total)
  • Try to add this in functions.php:

    add_filter('the_excerpt', 'do_shortcode');

    Hi, I’ve added this to a child functions file but it is still stripping the drop cap from the excerpts.

    Excerpts do that by design –

    http://codex.wordpress.org/Function_Reference/the_excerpt

    There are other plugins that let you control formatting of excerpts or you could modify your theme via a child theme.

    I have read elsewhere (at a couple of different places), that it is not possible to use shortcodes with excerpts. I did try a few other suggestions I found from searches, but nothing has worked.

    As a work around, I have started adding text to the excerpt field. I needed to turn this on first under screen options when in edit mode for a post. This field overrides the auto excerpt and allows me to keep the shortcode at the start of the post in the main text field.

    Thanks for your help anyway, I appreciate your response.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Shortcodes stripped in Excerpt’ is closed to new replies.