Support » Fixing WordPress » Shortcodes stopped working in custom fields

  • All of a sudden my shortcodes stopped working in my theme and custom fields. Any idea what could have happened? Was it the most recent 3.8.2 update? Earlier this week everything was working fine.

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • What theme? Did you check the theme authors support forum? What shortcodes? Did they come with the theme? Link?

    Thanks for answering. Something changed in the way shortcodes were rendered with the latest update so I just had to update my code a bit. Plus, a plugin got updated at the same time that threw a wrench in things. We’re back up and running so I appreciate you coming in and helping.

    grahamenglish – I’m experiencing this issue as well since this update. Can you share what you know about the shortcode update, and what you needed to do to fix?

    Any help appreciated. Thanks

    My developer took care of the problem. We had to adjust the code:

    <?php $downloadlinks = get_post_meta($post->ID, 'downloadlinks', $single = true); 
    
    if ($downloadlinks==''&& is_user_logged_in()){
    	$downloadlinks = print '<ul><li>There are no download links currently available.</li></ul>';
    } else {
    	if ( is_user_logged_in() ) { $downloadlinks = do_shortcode($downloadlinks); }
    };
    
    ?>

    Not sure if this helps. Hope it does.

    Thanks for the reply. My problem appears to be different than this unfortunately

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Shortcodes stopped working in custom fields’ is closed to new replies.