• Hi! I am a new user of this plugin. So, I have a little amount of knowledge of this plugin’s functionality. I did set up everything including multiple currencies, currency switcher, and even Openexchange Rates API. My issue is when I use the shortcode of the currency switcher on a page designed using Elementor page builder, the switcher does not appear. Any kind of help is appreciated.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author DoatKolom


    Hello @timaxx ,

    Thanks for using the x-currency plugin.

    Sorry for the inconvenience. We have added this issue to our task list. We will try to find and fix this problem as soon as possible.

    If you provide some screenshots of what you’re having trouble with, we can find the problem faster.

    Thanks again for using the X-Currency plugin.

    Thread Starter Tharusha Induwara


    Thanks for the update. I hope this issue will be resolved soon. Otherwise, the plugin would be great. Could you please specify the locations where you need the screenshots? (Plugin settings, elementor page or etc).

    Also, I noticed an additional issue too. When the X-currency plugin was activated, the Elementor products widget (Not any third-party addon widget) image sizes changed to full, not the pre-defined cropped size.

    Below image is before activating the plugin.

    Below image is after activating the plugin

    Also, this issue fixed right after deactivating the plugin.

    Plugin Author DoatKolom


    In our side, we didn’t find the problem.

    We tested with Elementor, WooCommerce plugin, and Astra theme. All are the latest version.

    1. https://i.ibb.co/Gv1H4qt/2023-07-14-14-13-27.png
    2. https://i.ibb.co/1KfsVpy/2023-07-14-14-16-53.png

    I think your theme or some plugin is conflicting with x-currency.

    To reproduce the problem on your side.

    1. Enable WordPress debug mode. https://wordpress.org/documentation/article/debugging-in-wordpress/
    2. Disable the caching plugin if it exists.
    3. Check the WordPress debug file and browser console (Maybe you will get some error).
    4. Check by changing theme.
    5. Check by disabling other plugins one by one.

    Hope you find where the problem is occurring. After reproduce the issue we will try to fix the problem.

    • This reply was modified 9 months, 1 week ago by DoatKolom.


    I’m experiencing the same issue. I placed the x-currency element into popups that I built using elementor. When I’m working on elementor on the backend, they shows up fine. But on the frontend, there’s only a blank space

    Plugin Author DoatKolom


    The shortcode not working in the Elementor page builder issue is fixed. We replaced the switcher react component with the web component. Please use the latest version.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Shortcodes not working with Elementor’ is closed to new replies.